summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-06-25 21:35:38 +0200
committerMaxime Gauduin2017-06-25 21:35:38 +0200
commitc154db02d6d5d0ccf3ef8f361a3b340cc8666b26 (patch)
tree1bd5e177b8d816d58e9055a4a7eb4209edcb2c08
parent450db464b88e123b4fc6312dd3cc5d5ad953f462 (diff)
downloadaur-c154db02d6d5d0ccf3ef8f361a3b340cc8666b26.tar.gz
3dstool 1.0.26-1
-rw-r--r--.SRCINFO23
-rw-r--r--3dstool-openssl1.0.patch13
-rw-r--r--3dstool-paths.patch (renamed from 00-3dstool-share-ignore.patch)7
-rw-r--r--PKGBUILD76
4 files changed, 68 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04d1e67af044..3c30afd5f395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Jun 25 19:35:38 UTC 2017
pkgbase = 3dstool
- pkgdesc = An all-in-one tool for extracting/creating 3ds roms.
+ pkgdesc = An all-in-one tool for extracting/creating 3ds roms
pkgver = 1.0.26
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/dnasdw/3dstool
arch = i686
arch = x86_64
- license = unknown
- makedepends = git
+ license = None
makedepends = cmake
- makedepends = glibc
- depends = openssl
- options = !strip
- source = https://github.com/dnasdw/3dstool/archive/v1.0.26.tar.gz
- source = 00-3dstool-share-ignore.patch
+ depends = curl
+ depends = glibc
+ depends = openssl-1.0
+ source = 3dstool-1.0.26.tar.gz::https://github.com/dnasdw/3dstool/archive/v1.0.26.tar.gz
+ source = 3dstool-paths.patch
+ source = 3dstool-openssl1.0.patch
sha256sums = 3c2288bac0d7a3d96416290c4032e5fc38776cef3ebfe0cb10d3faf14aab66f2
- sha256sums = 14cca789693c1c08ac435456bdd24c3e76c872cb02c1816cb021333c440d2786
+ sha256sums = 5ac00e5b56182ffde04c7b9ab2a5151e6cf575400705f0b061ff832116757582
+ sha256sums = f6099fde2c1cee1bba111ee112991f475ce29a56b55a17255d80f813dc2f598c
pkgname = 3dstool
diff --git a/3dstool-openssl1.0.patch b/3dstool-openssl1.0.patch
new file mode 100644
index 000000000000..2ccebab041c1
--- /dev/null
+++ b/3dstool-openssl1.0.patch
@@ -0,0 +1,13 @@
+diff -rupN 3dstool-1.0.25.orig/CMakeLists.txt 3dstool-1.0.25/CMakeLists.txt
+--- 3dstool-1.0.25.orig/CMakeLists.txt 2017-06-20 00:21:12.997972908 +0200
++++ 3dstool-1.0.25/CMakeLists.txt 2017-06-20 00:31:21.511945922 +0200
+@@ -41,6 +41,9 @@ include(AutoFiles)
+ if(USE_DEP)
+ ADD_DEP_INCLUDE_DIR("${ROOT_SOURCE_DIR}/dep")
+ ADD_DEP_LIBRARY_DIR("${ROOT_SOURCE_DIR}/dep")
++else()
++ ADD_DEP_INCLUDE_DIR("/usr/include/openssl-1.0")
++ ADD_DEP_LIBRARY_DIR("/usr/lib/openssl-1.0")
+ endif()
+ if(UNIX OR MINGW)
+ if(CYGWIN)
diff --git a/00-3dstool-share-ignore.patch b/3dstool-paths.patch
index 2ecf7db983fa..7082fb9a6e08 100644
--- a/00-3dstool-share-ignore.patch
+++ b/3dstool-paths.patch
@@ -1,6 +1,7 @@
---- 3dstool/src/romfs.cpp.orig
-+++ 3dstool/src/romfs.cpp
-@@ -265,7 +265,7 @@
+diff -rupN 3dstool-1.0.25.orig/src/romfs.cpp 3dstool-1.0.25/src/romfs.cpp
+--- 3dstool-1.0.25.orig/src/romfs.cpp 2017-06-19 23:30:45.261905149 +0200
++++ 3dstool-1.0.25/src/romfs.cpp 2017-06-19 23:32:12.444834329 +0200
+@@ -266,7 +266,7 @@ void CRomFs::buildIgnoreList()
{
m_vIgnoreList.clear();
m_vRemapIgnoreList.clear();
diff --git a/PKGBUILD b/PKGBUILD
index e35c562420e0..51fffc15a097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,50 @@
-# Maintainer: yubimusubi
-pkgbase=3dstool
-pkgname=('3dstool')
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: yubimusubi <possum+aur@possum.cc>
+
+pkgname=3dstool
pkgver=1.0.26
-pkgrel=0
-pkgdesc="An all-in-one tool for extracting/creating 3ds roms."
+pkgrel=1
+pkgdesc='An all-in-one tool for extracting/creating 3ds roms'
arch=('i686' 'x86_64')
-url="https://github.com/dnasdw/3dstool"
-license=('unknown') # FIXME
-depends=('openssl')
-makedepends=('git' 'cmake' 'glibc') # glibc provides iconv
-options=('!strip')
-
-source=(
- "https://github.com/dnasdw/3dstool/archive/v${pkgver}.tar.gz"
- '00-3dstool-share-ignore.patch'
-)
-sha256sums=(
- '3c2288bac0d7a3d96416290c4032e5fc38776cef3ebfe0cb10d3faf14aab66f2'
- '14cca789693c1c08ac435456bdd24c3e76c872cb02c1816cb021333c440d2786'
-)
+url='https://github.com/dnasdw/3dstool'
+license=('None')
+depends=('curl' 'glibc' 'openssl-1.0')
+makedepends=('cmake')
+source=("3dstool-${pkgver}.tar.gz::https://github.com/dnasdw/3dstool/archive/v${pkgver}.tar.gz"
+ '3dstool-paths.patch'
+ '3dstool-openssl1.0.patch')
+sha256sums=('3c2288bac0d7a3d96416290c4032e5fc38776cef3ebfe0cb10d3faf14aab66f2'
+ '5ac00e5b56182ffde04c7b9ab2a5151e6cf575400705f0b061ff832116757582'
+ 'f6099fde2c1cee1bba111ee112991f475ce29a56b55a17255d80f813dc2f598c')
prepare() {
- cd "$pkgbase-$pkgver"
+ cd 3dstool-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
- # Move ignore file into /usr/share
- patch -p1 < ../00-3dstool-share-ignore.patch
+ patch -Np1 -i ../3dstool-paths.patch
+ patch -Np1 -i ../3dstool-openssl1.0.patch
}
build() {
- cd "$pkgbase-$pkgver"
-
- # This is straight from the README
- mkdir -p project
- cd project
- cmake ..
- cmake ..
- make
+ cd 3dstool-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DUSE_DEP='OFF'
+ make
}
package() {
- cd "$pkgbase-$pkgver/project"
- make install # Actually installs to "../bin"
- install -d "$pkgdir/usr/bin/"
- install "../bin/3dstool" "$pkgdir/usr/bin/"
-
- # Move ignore file into /usr/share
- install -d "$pkgdir/usr/share/3dstool"
- install "../bin/ignore_3dstool.txt" "$pkgdir/usr/share/3dstool"
+ cd 3dstool-${pkgver}/build
+
+ make install
+
+ install -Dm 755 ../bin/3dstool -t "${pkgdir}"/usr/bin/
+ install -Dm 644 ../bin/ignore_3dstool.txt -t "${pkgdir}"/usr/share/3dstool/
}
+
+# vim: ts=2 sw=2 et: