summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Fuhry2023-08-29 22:07:48 -0400
committerDan Fuhry2023-08-29 23:13:06 -0400
commitc1693f10e3ec96dfd5283228d7b8f4991abbf53e (patch)
tree27dc63b255b2785ca1564babb049de701d581e7f
parentfeed7f9a34bb72c030669c3cf367a7841166a795 (diff)
downloadaur-c1693f10e3ec96dfd5283228d7b8f4991abbf53e.tar.gz
updpkg: envoyproxy 1.27.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--0002-luajit-use-correct-make-binary.patch48
-rw-r--r--PKGBUILD8
3 files changed, 58 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c19ed534cb44..ae252106179d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = envoyproxy
pkgdesc = A high performance, open source, general RPC framework that puts mobile and HTTP/2 first.
- pkgver = 1.26.2
+ pkgver = 1.27.0
pkgrel = 1
url = https://envoyproxy.io
arch = i686
@@ -17,9 +17,11 @@ pkgbase = envoyproxy
makedepends = perl
makedepends = python
makedepends = libxcrypt-compat
- source = https://github.com/envoyproxy/envoy/archive/v1.26.2.tar.gz
+ source = https://github.com/envoyproxy/envoy/archive/v1.27.0.tar.gz
source = 0001-arch-dynamically-link-libpsl.patch
- sha512sums = 12e138851f2f98e4c7f7c9e7e5f8c1198a9a0fc01f31527ff558ec48353f93dba63c36ba61d7a2e865bc5ad5c02c0c7b409683b975e05548210d27cdd60cb2ec
+ source = 0002-luajit-use-correct-make-binary.patch
+ sha512sums = de4d05962413d56f1ffcfe05266d1e3892bb48a6f313dda3dc34a436cec6631220b91a9d624c5f4f09653cf85f9498efec8bf5169ced4e527d55054788c7cc87
sha512sums = 58f7f40a420e1dc7ba845c5349a7596126b4eecc39ca15ebb94fbfe9cd944109318e7577329242164d4dd4ae3a99359723f41dc7265a0334cba06e556c7e8be3
+ sha512sums = 905643509ad1998c5bfe6854c97ad13cb1db1d981801876a98ca1c36cc93a63548501dd84e9f310735856095a097122756a68b7d0aea7797ac2e7f3f23d0bc99
pkgname = envoyproxy
diff --git a/0002-luajit-use-correct-make-binary.patch b/0002-luajit-use-correct-make-binary.patch
new file mode 100644
index 000000000000..3bf8b20c660f
--- /dev/null
+++ b/0002-luajit-use-correct-make-binary.patch
@@ -0,0 +1,48 @@
+From f61750d8b2983f211f5f3418c7fa48763dad0744 Mon Sep 17 00:00:00 2001
+From: Michael Kaufmann <michael.kaufmann@ergon.ch>
+Date: Fri, 25 Aug 2023 11:24:43 +0200
+Subject: [PATCH] build: use the correct "make" binary for building LuaJIT
+
+The "make" binary that is referenced by the environment variable "MAKE" must be
+used to build LuaJIT, not the "make" binary of the system.
+
+The build rules of "rules_foreign_cc" create an own "make" binary (currently
+GNU Make 4.3). The "MAKE" environment variable references this binary.
+
+LuaJIT's Makefile uses "make" recursively:
+
+default all $(INSTALL_DEP):
+ @echo "==== Building LuaJIT $(VERSION) ===="
+ $(MAKE) -C src
+
+This means that at this point, the "make" binary referenced by the "MAKE"
+environment variable will be invoked.
+
+The system's "make" binary may be newer than the "make" of "rules_foreign_cc"
+(e.g. GNU Make 4.4 vs GNU Make 4.3), and this can lead to errors, because the
+newer "make" passes information in the "MAKEFLAGS" environment variable to the
+older "make", and the older "make" does not understand this information:
+
+"internal error: invalid --jobserver-auth string 'fifo:/tmp/GMfifo359'. Stop."
+
+The solution is to build LuaJIT with a single version of GNU Make.
+
+Fixes https://github.com/envoyproxy/envoy/issues/28633
+
+Signed-off-by: Michael Kaufmann <michael.kaufmann@ergon.ch>
+---
+ bazel/foreign_cc/luajit.patch | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff -Naur a/bazel/foreign_cc/luajit.patch b/bazel/foreign_cc/luajit.patch
+--- a/bazel/foreign_cc/luajit.patch 2023-07-26 13:15:12.000000000 -0400
++++ b/bazel/foreign_cc/luajit.patch 2023-08-29 21:57:56.311852727 -0400
+@@ -166,7 +166,7 @@
+ + with open("clang-asan-blocklist.txt", "w") as f:
+ + f.write("fun:*\n")
+ +
+-+ os.system('make -j{} V=1 PREFIX="{}" install'.format(os.cpu_count(), args.prefix))
+++ os.system('"{}" -j{} V=1 PREFIX="{}" install'.format(os.environ["MAKE"], os.cpu_count(), args.prefix))
+ +
+ +def win_main():
+ + src_dir = os.path.dirname(os.path.realpath(__file__))
diff --git a/PKGBUILD b/PKGBUILD
index 879bb662ce38..ed490edc2e09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Dan Fuhry <dan@fuhry.com>
pkgname=envoyproxy
-pkgver=1.26.2
+pkgver=1.27.0
pkgrel=1
pkgdesc="A high performance, open source, general RPC framework that puts mobile and HTTP/2 first."
arch=('i686' 'x86_64')
@@ -26,9 +26,11 @@ makedepends=(
source=(
"https://github.com/$pkgname/envoy/archive/v$pkgver.tar.gz"
0001-arch-dynamically-link-libpsl.patch
+ 0002-luajit-use-correct-make-binary.patch
)
-sha512sums=('12e138851f2f98e4c7f7c9e7e5f8c1198a9a0fc01f31527ff558ec48353f93dba63c36ba61d7a2e865bc5ad5c02c0c7b409683b975e05548210d27cdd60cb2ec'
- '58f7f40a420e1dc7ba845c5349a7596126b4eecc39ca15ebb94fbfe9cd944109318e7577329242164d4dd4ae3a99359723f41dc7265a0334cba06e556c7e8be3')
+sha512sums=('de4d05962413d56f1ffcfe05266d1e3892bb48a6f313dda3dc34a436cec6631220b91a9d624c5f4f09653cf85f9498efec8bf5169ced4e527d55054788c7cc87'
+ '58f7f40a420e1dc7ba845c5349a7596126b4eecc39ca15ebb94fbfe9cd944109318e7577329242164d4dd4ae3a99359723f41dc7265a0334cba06e556c7e8be3'
+ '905643509ad1998c5bfe6854c97ad13cb1db1d981801876a98ca1c36cc93a63548501dd84e9f310735856095a097122756a68b7d0aea7797ac2e7f3f23d0bc99')
prepare() {
cd "envoy-$pkgver"