summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonard de Ruijter2017-10-19 16:20:59 +0200
committerLeonard de Ruijter2017-10-19 16:20:59 +0200
commitc187a6088636a522077997a4139fb3bb6f472083 (patch)
tree6f5096bf617f626af4bd49d1b1edf196722f6fae
parentae30f56c74c483922a9b01211612a68d84c4fbf0 (diff)
downloadaur-c187a6088636a522077997a4139fb3bb6f472083.tar.gz
Update to kh7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--fixssl.patch35
3 files changed, 8 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a308124d8c06..24d311bcda68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Sep 25 04:10:45 UTC 2017
+# Thu Oct 19 14:20:49 UTC 2017
pkgbase = icecast-kh
pkgdesc = The KH branche extends the official release of Icecast with features that may be (if found to be working out well) merged into the next official release.
- pkgver = 2.4.0_kh6
- pkgrel = 3
+ pkgver = 2.4.0_kh7
+ pkgrel = 1
url = http://karlheyes.github.com
install = icecast-kh.install
arch = i686
@@ -22,15 +22,13 @@ pkgbase = icecast-kh
conflicts = icecast-kh-git
backup = etc/icecast.xml
backup = etc/logrotate.d/icecast
- source = https://github.com/karlheyes/icecast-kh/archive/icecast-2.4.0-kh6.tar.gz
+ source = https://github.com/karlheyes/icecast-kh/archive/icecast-2.4.0-kh7.tar.gz
source = icecast-kh.logrotate
source = start-by-icecast.patch
- source = fixssl.patch
source = icecast-kh.service
- sha256sums = 53f842c7ed41004a853a3d6b814878663c601b321058298e7d68c3f8b6055f16
+ sha256sums = 69267eb1ca9eca451056e53efd286e6d911821257910c0f7007f70b9dc111f60
sha256sums = 46f4d6942223a6d82f0b188e616a8a9cda3911663d59cc976c44b7a9822149f0
sha256sums = b09ac79daccf8347ead4088aca31d2214dcd27e211e9ee2e96ef1a44b65df84f
- sha256sums = 71880af596141b4f4d3766b7336bb40deffbd34d546fb3d3675f99f3ac84cccd
sha256sums = 4b7f31aff45c6a572d54279531b7944567363d4c2bcd86d9c48887dc7da80a73
pkgname = icecast-kh
diff --git a/PKGBUILD b/PKGBUILD
index 21efa0b64179..f3bcf1437980 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Leonard de Ruijter <dev@systeemdenker.nl>
pkgname=icecast-kh
-pkgver=2.4.0_kh6
-pkgrel=3
+pkgver=2.4.0_kh7
+pkgrel=1
pkgdesc='The KH branche extends the official release of Icecast with features that may be (if found to be working out well) merged into the next official release.'
arch=('i686' 'x86_64')
url='http://karlheyes.github.com'
@@ -17,19 +17,16 @@ install=$pkgname.install
source=(https://github.com/karlheyes/$pkgname/archive/${pkgname/-*}-${pkgver//_/-}.tar.gz
$pkgname.logrotate
start-by-icecast.patch
-fixssl.patch
$pkgname.service)
-sha256sums=('53f842c7ed41004a853a3d6b814878663c601b321058298e7d68c3f8b6055f16'
+sha256sums=('69267eb1ca9eca451056e53efd286e6d911821257910c0f7007f70b9dc111f60'
'46f4d6942223a6d82f0b188e616a8a9cda3911663d59cc976c44b7a9822149f0'
'b09ac79daccf8347ead4088aca31d2214dcd27e211e9ee2e96ef1a44b65df84f'
- '71880af596141b4f4d3766b7336bb40deffbd34d546fb3d3675f99f3ac84cccd'
'4b7f31aff45c6a572d54279531b7944567363d4c2bcd86d9c48887dc7da80a73')
_srcpath=$pkgname-${pkgname/-*}-${pkgver//_/-}
build() {
cd "$srcdir/$_srcpath"
patch -Np1 -i "${srcdir}/start-by-icecast.patch"
- patch -Np1 -i "${srcdir}/fixssl.patch"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
diff --git a/fixssl.patch b/fixssl.patch
deleted file mode 100644
index bc3c3f9387ac..000000000000
--- a/fixssl.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/src/connection.c b/src/connection.c
-index 9af06b2..157556c 100644
---- a/src/connection.c
-+++ b/src/connection.c
-@@ -84,16 +84,25 @@ static DH *get_dh2048()
- 0x02,
- };
- DH *dh;
-+ BIGNUM *p, *g;
-
-- if ((dh=DH_new()) == NULL) return NULL;
-- dh->p = BN_bin2bn (dh2048_p, sizeof(dh2048_p), NULL);
-- dh->g = BN_bin2bn (dh2048_g, sizeof(dh2048_g), NULL);
-- if ((dh->p == NULL) || (dh->g == NULL))
-+ if ((dh=DH_new()) == NULL) return NULL;
-+ p = BN_bin2bn (dh2048_p, sizeof(dh2048_p), NULL);
-+ g = BN_bin2bn (dh2048_g, sizeof(dh2048_g), NULL);
-+ if ((p == NULL) || (g == NULL))
- {
-+ BN_free (p);
-+ BN_free (g);
- DH_free (dh);
- return NULL;
- }
-- return dh;
-+#if OPENSSL_VERSION_NUMBER >= 0x10100005L
-+ DH_set0_pqg(dh, p, NULL, g);
-+#else
-+ dh->p = p;
-+ dh->g = g;
-+#endif
-+ return dh;
- }
- #endif
- #endif // END DH CODE