summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2019-02-03 21:24:17 +0000
committerLeonidas Spyropoulos2019-02-03 21:24:17 +0000
commitc18929836dc26fd6dcc7400bceb76d34c5822600 (patch)
tree37b4b5e4e51bc61d372a2eafa4ff3ae1b01a0537
parent67d69c328e4e6608a467b0ba8797493268acf6e6 (diff)
downloadaur-c18929836dc26fd6dcc7400bceb76d34c5822600.tar.gz
upgpkg: aarchup 2.1.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
-rw-r--r--aarchup.install19
3 files changed, 18 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a40dd6d868e8..e6aa30f76503 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = aarchup
pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
- pkgver = 1.8.3
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/inglor/aarchup
- install = aarchup.install
arch = i686
arch = x86_64
license = GPL3
makedepends = libnotify
- makedepends = autoconf
+ makedepends = cmake
+ makedepends = ninja
makedepends = gzip
depends = libnotify
depends = gtk2
optdepends = auracle: AUR support(--aur)
provides = aarchup
- source = aarchup-1.8.3.zip::https://github.com/inglor/aarchup/archive/1.8.3.zip
- sha256sums = 1e5440ea6ce8ddded31f6d9ab9f62743c99ba9b56f65fd8f92a965d7970ead3e
+ source = aarchup-2.1.0.tar.gz::https://github.com/inglor/aarchup/archive/2.1.0.tar.gz
+ sha256sums = 51adb6e1ebf500281c2874dbf624a869f83c927c7aac6e19645fdc0e64cddec7
pkgname = aarchup
diff --git a/PKGBUILD b/PKGBUILD
index 8815d1a9b2a1..81f799d114d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andrew Kravchuk <awkravchuk at gmail dot com>
#
pkgname="aarchup"
-pkgver=1.8.3
+pkgver=2.1.0
pkgrel=1
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
url="https://github.com/inglor/aarchup"
@@ -13,27 +13,27 @@ arch=('i686' 'x86_64')
license=('GPL3')
provides=("${pkgname}")
depends=('libnotify' 'gtk2')
-makedepends=('libnotify' 'autoconf' 'gzip')
+makedepends=('libnotify' 'cmake' 'ninja' 'gzip')
optdepends=('auracle: AUR support(--aur)')
-install='aarchup.install'
-source=("${pkgname}-${pkgver}.zip::${url}/archive/${pkgver}.zip")
-sha256sums=('1e5440ea6ce8ddded31f6d9ab9f62743c99ba9b56f65fd8f92a965d7970ead3e')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('51adb6e1ebf500281c2874dbf624a869f83c927c7aac6e19645fdc0e64cddec7')
+
prepare() {
- mv "${pkgname}-${pkgver}"/src/* "${pkgname}-${pkgver}"
- rmdir "${pkgname}-${pkgver}"/src
+ mkdir "${pkgname}-${pkgver}/build"
}
build() {
- cd "${pkgname}-${pkgver}"
- autoconf
- ./configure --prefix=/usr
- make
+ cd "${pkgname}-${pkgver}/build"
+ cmake .. -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ ninja all
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${pkgname}-${pkgver}/build"
+ DESTDIR="$pkgdir" ninja install
}
# vim: set ts=4 sw=4 et syn=sh ft=sh:
diff --git a/aarchup.install b/aarchup.install
deleted file mode 100644
index 2eafe0eb4a84..000000000000
--- a/aarchup.install
+++ /dev/null
@@ -1,19 +0,0 @@
-post_upgrade() {
- cat << EOF
- To avoid problems with partial upgrades (http://gist.io/5660494) we no longer
- use the combination of pacman -Sy/-Qu to check for updates. We now use checkupdates.
-
- As a result of this --ignore-disconnect was removed. Please remove it from your configurations, if you were using it.
-
- If you were using --command|-c, note that the command has to check for updates now
- since we no longer call pacman -Sy.
-EOF
-}
-
-post_install() {
- cat <<EOF
- Please check man pages for installation instructions.
- If you have any problems or would like to request a feature,
- check https://bbs.archlinux.org/viewtopic.php?id=119129
-EOF
-}