aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2013-10-05 11:09:38 -0700
committeryar2015-07-03 16:58:29 -0700
commitc18aba0020103dc582e43b1a44d138b219539470 (patch)
treea6e47a4b66e1256a93c79f1e71e121403e942c0e
parente4309f4f12bc48257e29a829b82e926023b2a0b1 (diff)
downloadaur-c18aba0020103dc582e43b1a44d138b219539470.tar.gz
stop using KERNEL_VERSION in install scripts
one less file to bump not sure what weird scenarios would cause this to break ... someone who hand-edits the source line without editing the pkgver/pkgrel??
-rw-r--r--PKGBUILD1
-rw-r--r--install8
2 files changed, 2 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ce3cc13b63d..e6cec854701e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -66,7 +66,6 @@ package_linux-linode() {
install -D -m644 "${srcdir}/preset" "${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset"
sed \
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/" \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" \
-i "${startdir}/install"
sed \
-e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${pkgname}\"|" \
diff --git a/install b/install
index 25c7b9090237..6ce2c1733241 100644
--- a/install
+++ b/install
@@ -1,14 +1,10 @@
-# arg 1: the new package version
-# arg 2: the old package version
-
KERNEL_NAME=-linode
-KERNEL_VERSION=3.11.4-1-linode
export PATH='/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
post_install () {
echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
+ depmod ${1##*:}${KERNEL_NAME}
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
mkinitcpio -p linux${KERNEL_NAME}
}
@@ -16,7 +12,7 @@ post_install () {
post_upgrade() {
rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
+ depmod ${1##*:}${KERNEL_NAME}
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
mkinitcpio -p linux${KERNEL_NAME}
}