summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Jacocks2024-03-24 01:51:42 -0400
committerAlexander Jacocks2024-03-24 01:51:42 -0400
commitc18f7881097f0109acd0c99a9201442baec247d4 (patch)
treee0d960ed0dca750e42a5542e25d86a6d60ff1c08
parent3f2d8ebdccfd80589a3665ee2222452be0919335 (diff)
downloadaur-c18f7881097f0109acd0c99a9201442baec247d4.tar.gz
add optional building of xhfs with tcl+tk presence
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD10
2 files changed, 11 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b13230603303..18b2fe72d7e7 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,8 @@ pkgbase = hfsutils
arch = x86_64
license = GPL2
depends = glibc
+ optdepends = tcl: xhfs GUI
+ optdepends = tk: xhfs GUI
source = https://deb.debian.org/debian/pool/main/h/hfsutils/hfsutils_3.2.6.orig.tar.gz
source = https://deb.debian.org/debian/pool/main/h/hfsutils/hfsutils_3.2.6-15.debian.tar.xz
sha256sums = bc9d22d6d252b920ec9cdf18e00b7655a6189b3f34f42e58d5bb152957289840
diff --git a/PKGBUILD b/PKGBUILD
index b952b2ad2650..951aae260e28 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Cody P Schafer <dev@codyps.com>
# Maintainer: Michał Wojdyła <micwoj9292@gmail.com>
+# Maintainer: Alexander Jacocks <alexander@redhat.com>
# Contributor: Pablo Lezaeta <prflr88@gmail.com>
pkgname=hfsutils
pkgver=3.2.6_p15
@@ -9,6 +10,8 @@ arch=('x86_64')
license=('GPL2')
url="https://www.mars.org/home/rob/proj/hfs/"
depends=(glibc)
+optdepends=('tcl: xhfs GUI'
+ 'tk: xhfs GUI')
source=(
"https://deb.debian.org/debian/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver/_p*}.orig.tar.gz"
"https://deb.debian.org/debian/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver/_p/-}.debian.tar.xz"
@@ -25,7 +28,12 @@ prepare() {
build() {
cd "${pkgname}-${pkgver%_p*}"
autoreconf -fi
- ./configure
+ # test for tcl and tk presence
+ if [ -x /usr/bin/tclsh -a -x /usr/bin/wish ]; then
+ ./configure --with-tcl --with-tk
+ else
+ ./configure
+ fi
make prefix=/usr
make -C hfsck prefix=/usr
}