summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-11 10:50:36 -0700
committerMark Wagie2021-02-11 10:50:36 -0700
commitc1a567fb83017f7ec7d950ba607fa5348ccb66de (patch)
treeaebe6b3b90318a1e33b8ade790c241db4e7c1f01
parent388456947ecf9a7e5cbe67ea8fd5aa1ee0243b58 (diff)
downloadaur-c1a567fb83017f7ec7d950ba607fa5348ccb66de.tar.gz
cmake package guidelines, update Maintainers
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD12
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 349077395b39..85fec9a34025 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kindd
pkgdesc = A Kindful dd GUI written in Qt Quick
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/LinArcX/Kindd
arch = any
license = GPL3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index dba200a4b93f..8fb5c9ca3060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer:
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: LinArcx <linarcx at gmail.com>
pkgname=kindd
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Kindful dd GUI written in Qt Quick"
arch=('any')
url="https://github.com/LinArcX/Kindd"
@@ -14,15 +15,16 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('e596f1b1577ff3e83a779e6181252ae2f09731f513d17dd6b95cbc2cf204654f')
build() {
- cd "$pkgname-$pkgver"
- cmake -B build -S . \
+ cmake -B build -S "$pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
make -C build
}
package() {
cd "$pkgname-$pkgver"
- install -Dm755 "build/core/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm755 "$srcdir/build/core/$pkgname" -t "$pkgdir/usr/bin"
install -Dm644 "assets/appconf/$pkgname.desktop" -t \
"$pkgdir/usr/share/applications"
install -Dm644 "assets/appconf/$pkgname.svg" -t \