summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2017-03-30 08:43:31 +0300
committerMantas Mikulėnas2017-03-30 08:46:38 +0300
commitc1c56cb41ef0200043233f35f600e02563bfbfcd (patch)
tree9cf73b7103f840aecbd2f816fbf4f2f9be1a9b63
parent71a44702a2babc230be49807b4d1f0f25d47b709 (diff)
downloadaur-c1c56cb41ef0200043233f35f600e02563bfbfcd.tar.gz
release oor 1.1.1.r4
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
-rw-r--r--lispd.service8
-rw-r--r--oor.service8
4 files changed, 41 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b3d428c9d8a..8b24d443541b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Mar 30 05:30:16 UTC 2017
-pkgbase = lispmob
- pkgdesc = Locator/ID Separation Protocol (LISP) and LISP Mobile Node implementation
- pkgver = 0.5.2.1
+# Thu Mar 30 05:46:32 UTC 2017
+pkgbase = oor
+ pkgdesc = Open Overlay Router (formerly LISPmob) - Locator/ID Separation Protocol (LISP) and LISP Mobile Node implementation
+ pkgver = 1.1.1.r4.gc4b9c95
pkgrel = 1
- url = http://lispmob.org
+ url = http://openoverlayrouter.org/
arch = x86_64
arch = i686
arch = armv6h
@@ -14,11 +14,13 @@ pkgbase = lispmob
depends = openssl
depends = confuse
depends = libcap
- backup = etc/lispd.conf
- source = git+https://github.com/LISPmob/lispmob.git#tag=0.5.2.1
- source = lispd.service
+ provides = lispmob
+ replaces = lispmob
+ backup = etc/oor.conf
+ source = git+https://github.com/OpenOverlayRouter/oor#commit=c4b9c950107a57db2ab7327b7f2d1d738c653512
+ source = oor.service
sha256sums = SKIP
- sha256sums = dcad9ed9b3f643794c5021d4cbddf4fa0ba99177465394ecdcf943fcf8019520
+ sha256sums = b952f567e6c506d09aab10b4fae49c9cee31affb89b7a18040c2fa7f1a8df153
-pkgname = lispmob
+pkgname = oor
diff --git a/PKGBUILD b/PKGBUILD
index 7f9f23271307..ace411b68bb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,36 @@
-# Maintainer: Michiel <code[at]m01[dot]eu>
-pkgname=lispmob
-pkgver=0.5.2.1
+pkgname=oor
+pkgver=1.1.1.r4.gc4b9c95
pkgrel=1
-pkgdesc="Locator/ID Separation Protocol (LISP) and LISP Mobile Node implementation"
-url="http://lispmob.org"
+pkgdesc="Open Overlay Router (formerly LISPmob) - Locator/ID Separation Protocol (LISP) and LISP Mobile Node implementation"
+url="http://openoverlayrouter.org/"
arch=('x86_64' 'i686' 'armv6h')
license=('GPL2')
depends=('openssl' 'confuse' 'libcap')
makedepends=('git' 'gengetopt')
-backup=("etc/lispd.conf")
-source=("git+https://github.com/LISPmob/lispmob.git#tag=${pkgver}"
- "lispd.service")
+provides=('lispmob')
+replaces=('lispmob')
+backup=("etc/oor.conf")
+_commit=c4b9c950107a57db2ab7327b7f2d1d738c653512
+source=("git+https://github.com/OpenOverlayRouter/oor#commit=$_commit"
+ "oor.service")
sha256sums=('SKIP'
- 'dcad9ed9b3f643794c5021d4cbddf4fa0ba99177465394ecdcf943fcf8019520')
+ 'b952f567e6c506d09aab10b4fae49c9cee31affb89b7a18040c2fa7f1a8df153')
+
+pkgver() {
+ cd oor
+ git describe | sed 's/^v//; s/-/.r/; s/-/./'
+}
build() {
- cd "${srcdir}/${pkgname}"
+ cd oor
make
}
package() {
- cd "${srcdir}/${pkgname}"
- make PREFIX="/usr/bin/" DESTDIR="${pkgdir}" install
- install -Dm644 "${srcdir}/${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "${srcdir}/lispd.service" "$pkgdir/etc/systemd/system/lispd.service"
- install -Dm644 "${srcdir}/${pkgname}/lispd/lispd.conf.example" "$pkgdir/etc/lispd.conf"
+ cd oor
+ make PREFIX="/usr/bin/" DESTDIR="$pkgdir" install
+ install -Dm644 oor/oor.conf.example "$pkgdir"/etc/oor.conf
+ install -Dm644 "$srcdir"/oor.service "$pkgdir"/usr/lib/systemd/system/oor.service
}
# vim:set ts=2 sw=2 et:
diff --git a/lispd.service b/lispd.service
deleted file mode 100644
index 92940561a706..000000000000
--- a/lispd.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=LISPmob service
-
-[Service]
-ExecStart=/usr/bin/lispd
-
-[Install]
-WantedBy=multi-user.target
diff --git a/oor.service b/oor.service
new file mode 100644
index 000000000000..f67edc5c9696
--- /dev/null
+++ b/oor.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Open Overlay Router LISP Daemon
+
+[Service]
+ExecStart=/usr/bin/oor
+
+[Install]
+WantedBy=multi-user.target