summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-06-08 08:32:28 -0400
committerJameson Pugh2015-06-08 08:32:28 -0400
commitc1e332e60d3b7b363d871425814044df49543330 (patch)
tree5b92621e83ab81d1dc651fbef43ffd244b29bc73
downloadaur-c1e332e60d3b7b363d871425814044df49543330.tar.gz
Initial commit using aur2git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..999e2ff21569
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Tue May 26 13:40:14 UTC 2015
+pkgbase = python2-regex
+ pkgdesc = Alternative regular expression module, to replace re.
+ pkgver = 0.1.20141024
+ pkgrel = 1
+ url = https://bitbucket.org/mrabarnett/mrab-regex
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = python2-distribute
+ depends = python2
+ conflicts = python2-regex-hg
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/python-regex_0.1.20141024.orig.tar.gz
+ sha256sums = 8bd2dbf096bcfa881bd7e06093037037a7315e82d0e74441338f4b6492037801
+
+pkgname = python2-regex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc53d59ec78c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Spyros Stathopoulos <foucault.online@gmail.com>
+pkgname=python2-regex
+pkgver=0.1.20141024
+pkgrel=1
+pkgdesc="Alternative regular expression module, to replace re."
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/mrabarnett/mrab-regex"
+license=('custom')
+depends=('python2')
+makedepends=('python2-distribute')
+conflicts=('python2-regex-hg')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/python-regex_${pkgver}.orig.tar.gz")
+sha256sums=('8bd2dbf096bcfa881bd7e06093037037a7315e82d0e74441338f4b6492037801')
+
+build() {
+ cd "$srcdir/regex-2014.10.24"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/regex-2014.10.24"
+
+ python2 setup.py install --prefix=/usr --root="${pkgdir}"
+}
+