summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-05 00:01:07 +0000
committerBioArchLinuxBot2023-06-05 00:01:07 +0000
commitc209c6f0b2b55864f545d45bf6e791782c45b37a (patch)
tree81181b419451049694952def30b59da88bf70015
parent30c84a5906b2240ca7f741719aa489a9b838133f (diff)
downloadaur-c209c6f0b2b55864f545d45bf6e791782c45b37a.tar.gz
[lilac] updated to 0.21-4
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD36
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22fe149cbbca..2d9bdd7318b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-evaluate
pkgdesc = Parsing and Evaluation Tools that Provide More Details than the Default
pkgver = 0.21
- pkgrel = 1
+ pkgrel = 4
url = https://cran.r-project.org/package=evaluate
arch = any
license = MIT
@@ -12,6 +12,7 @@ pkgbase = r-evaluate
optdepends = r-testthat
optdepends = r-withr
source = https://cran.r-project.org/src/contrib/evaluate_0.21.tar.gz
+ md5sums = fcd53297915079edf4f846d0c6489379
sha256sums = 3178c99cee8917d7d128806d064d4fecce7845ed07f42e759dcc0adda89c22b9
pkgname = r-evaluate
diff --git a/PKGBUILD b/PKGBUILD
index 0fe72e89c332..8bfd331f2bf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,42 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <alex.branham@gmail.com>
-_cranname=evaluate
-_cranver=0.21
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=evaluate
+_pkgver=0.21
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=4
pkgdesc="Parsing and Evaluation Tools that Provide More Details than the Default"
arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
+url="https://cran.r-project.org/package=${_pkgname}"
license=(MIT)
-depends=(r)
+depends=(
+ r
+)
optdepends=(
- r-covr
- r-ggplot2
- r-rlang
- r-testthat
- r-withr
+ r-covr
+ r-ggplot2
+ r-rlang
+ r-testthat
+ r-withr
)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('fcd53297915079edf4f846d0c6489379')
sha256sums=('3178c99cee8917d7d128806d064d4fecce7845ed07f42e759dcc0adda89c22b9')
build() {
mkdir -p build
- R CMD INSTALL "$_cranname" -l build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
install -d "$pkgdir/usr/lib/R/library"
- cp -a --no-preserve=ownership "build/$_cranname" "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
install -d "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "/usr/lib/R/library/$_cranname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}