summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNguyễn Hồng Hiệp2024-01-31 20:32:43 +0700
committerNguyễn Hồng Hiệp2024-01-31 20:32:43 +0700
commitc265da3077265a2166d10cf3779a8531b0f12d50 (patch)
tree0f5a5e195ac240c400724fd1a414db727f2bc44d
parent646844f00456f015ad9dda47141f8bdac023fd73 (diff)
downloadaur-c265da3077265a2166d10cf3779a8531b0f12d50.tar.gz
bump!: bump version to 2.3.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a175927177e4..abd66d66bc9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = mechvibes
pkgdesc = Play mechanical keyboard sounds as you type.
- pkgver = 2.3.0
+ pkgver = 2.3.4
pkgrel = 1
url = https://mechvibes.com
install = mechvibes.install
arch = x86_64
groups =
- license = GNU
+ license = MIT
depends = alsa-lib
depends = atk
depends = at-spi2-atk
@@ -42,7 +42,7 @@ pkgbase = mechvibes
depends = xdg-utils
options = !strip
options = !emptydirs
- source = https://github.com/hainguyents13/mechvibes/releases/download/v2.3.0/mechvibes_2.3.0_amd64.deb
- md5sums = 953bf957b816a0f1c140e1b6b0b57065
+ source = https://github.com/hainguyents13/mechvibes/releases/download/v2.3.4/mechvibes_2.3.4_amd64.deb
+ md5sums = 470f65983c996aac5b48beaaf0cd4ae8
pkgname = mechvibes
diff --git a/PKGBUILD b/PKGBUILD
index 7f3e764069e6..a53e466afd1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
-# Generated by debtap
-# Maintainer: ajiepangestu
-# Contributor:
+# Maintainer: justanoobcoder <syaorancode@gmail.com>
+
+_github_user="hainguyents13"
+_github_repo="mechvibes"
+
pkgname=mechvibes
-pkgver=2.3.0
+pkgver=2.3.4
pkgrel=1
pkgdesc="Play mechanical keyboard sounds as you type."
arch=('x86_64')
url="https://mechvibes.com"
-license=('GNU')
+license=('MIT')
groups=('')
depends=('alsa-lib' 'atk' 'at-spi2-atk' 'at-spi2-core' 'cairo' 'dbus' 'desktop-file-utils' 'expat' 'gdk-pixbuf2' 'glib2' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk3' 'libcups' 'libnotify' 'libsecret' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'pango' 'util-linux-libs' 'xdg-utils')
options=('!strip' '!emptydirs')
install=${pkgname}.install
-source=("https://github.com/hainguyents13/mechvibes/releases/download/v${pkgver}/mechvibes_${pkgver}_amd64.deb")
-md5sums=('953bf957b816a0f1c140e1b6b0b57065')
+source=("https://github.com/${_github_user}/${_github_repo}/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb")
+md5sums=('470f65983c996aac5b48beaaf0cd4ae8')
-package(){
+package() {
# Extract package data
tar xf data.tar.xz -C "${pkgdir}"
# Install Icon
for i in 16x16 24x24 32x32 48x48 64x64 128x128 256x256; do
install -Dm644 "$pkgdir"/usr/share/icons/hicolor/0x0/apps/"$pkgname".png \
- "$pkgdir"/usr/share/icons/hicolor/"$i"/apps/"$pkgname".png
+ "$pkgdir"/usr/share/icons/hicolor/"$i"/apps/"$pkgname".png
done
}