summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A.2023-11-20 09:28:25 +0100
committerPhilipp A.2023-11-20 09:28:25 +0100
commitc266a0a089cd46aff113bce9deb4af06e2ab4097 (patch)
tree717f38dc5af6cb17f895881e9e6515a28c135e3c
parent06edc8b455d1a90fa370304370fa2f49baab6723 (diff)
downloadaur-c266a0a089cd46aff113bce9deb4af06e2ab4097.tar.gz
v1.9.6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daaf769ec989..57efa2ac59bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = scanpy
pkgdesc = Single-Cell Analysis in Python
- pkgver = 1.9.5
+ pkgver = 1.9.6
pkgrel = 1
url = https://github.com/theislab/scanpy
arch = any
license = BSD
- makedepends = python-flit-core
- makedepends = python-setuptools-scm
+ makedepends = python-hatch
+ makedepends = python-hatch-vcs
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
depends = python-anndata>=0.7.4
depends = python-numpy>=1.17.0
depends = python-matplotlib>=3.4
- depends = python-pandas>=1.0
+ depends = python-pandas>=1.1.1
depends = python-scipy>=1.4
depends = python-seaborn
depends = python-h5py
@@ -44,7 +44,7 @@ pkgbase = scanpy
optdepends = python-dask: Dask parallelization
provides = scanpy
provides = python-scanpy
- source = https://files.pythonhosted.org/packages/source/s/scanpy/scanpy-1.9.5.tar.gz
- sha256sums = 1d90f95cd5e103c9e0cc41fd84c1f2d81d86d6337cbe294316578ed071d39d82
+ source = https://files.pythonhosted.org/packages/source/s/scanpy/scanpy-1.9.6.tar.gz
+ sha256sums = b2f24e6f220cb9d4d893b24f6899ba1a14cf2fef50b7e05bb37980c78de8a013
pkgname = scanpy
diff --git a/PKGBUILD b/PKGBUILD
index bf414dd69c65..faad90b7bc4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=scanpy
-pkgver=1.9.5
+pkgver=1.9.6
pkgrel=1
pkgdesc='Single-Cell Analysis in Python'
arch=(any)
@@ -12,7 +12,7 @@ depends=(
'python-anndata>=0.7.4'
'python-numpy>=1.17.0'
'python-matplotlib>=3.4'
- 'python-pandas>=1.0'
+ 'python-pandas>=1.1.1'
'python-scipy>=1.4'
python-seaborn
python-h5py
@@ -44,14 +44,13 @@ optdepends=(
'rapids-cugraph: NVIDIA RAPIDS acceleration'
'python-dask: Dask parallelization'
)
-makedepends=(python-flit-core python-setuptools-scm python-build python-installer python-wheel)
+makedepends=(python-hatch python-hatch-vcs python-build python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('1d90f95cd5e103c9e0cc41fd84c1f2d81d86d6337cbe294316578ed071d39d82')
+sha256sums=('b2f24e6f220cb9d4d893b24f6899ba1a14cf2fef50b7e05bb37980c78de8a013')
build() {
cd "$pkgname-$pkgver"
- # no idea why the dep check doesn’t work …
- python -m build --wheel --no-isolation --skip-dependency-check
+ python -m build --wheel --no-isolation
}
package() {