summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-10-01 14:53:06 -0400
committerDarvin Delgado2023-10-01 14:53:06 -0400
commitc2713b0ebf0869d3fadc7521a102ca72a953ee8d (patch)
tree643995e97f8a6ca445618984becd5067c77f7b24
parentd0b80a273e2d8b1ef00a7b3043279afcbc92be58 (diff)
downloadaur-c2713b0ebf0869d3fadc7521a102ca72a953ee8d.tar.gz
add missing dependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eef3e6b6d43a..ea5cd204f574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = lib32-mangohud-git
pkgdesc = 32-bit libraries for MangoHud and MangoApp
- pkgver = 0.6.9.1.r84.gbc8acf9
- pkgrel = 2
+ pkgver = 0.7.0.r11.gefd1c07
+ pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
makedepends = git
- makedepends = glfw-x11
makedepends = glslang
makedepends = lib32-cmocka
makedepends = lib32-libglvnd
@@ -17,6 +16,7 @@ pkgbase = lib32-mangohud-git
depends = lib32-dbus
depends = lib32-gcc-libs
depends = lib32-libx11
+ depends = lib32-sdl2
depends = lib32-vulkan-icd-loader
provides = lib32-mangohud
conflicts = lib32-mangohud
diff --git a/PKGBUILD b/PKGBUILD
index 1b8866df3750..789f803f7184 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
pkgname=lib32-mangohud-git
-pkgver=0.6.9.1.r84.gbc8acf9
-pkgrel=2
+pkgver=0.7.0.r11.gefd1c07
+pkgrel=1
pkgdesc="32-bit libraries for MangoHud and MangoApp"
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'glfw-x11' 'glslang' 'lib32-cmocka' 'lib32-libglvnd' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako')
-depends=('lib32-dbus' 'lib32-gcc-libs' 'lib32-libx11' 'lib32-vulkan-icd-loader')
+makedepends=('git' 'glslang' 'lib32-cmocka' 'lib32-libglvnd' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako')
+depends=('lib32-dbus' 'lib32-gcc-libs' 'lib32-libx11' 'lib32-sdl2' 'lib32-vulkan-icd-loader')
provides=('lib32-mangohud')
conflicts=('lib32-mangohud')
source=("$pkgname::git+$url")
@@ -38,7 +38,7 @@ build() {
}
package() {
- meson install -C build --tags runtime,mangoapp --destdir "$pkgdir"
+ meson install -C build --tags runtime --destdir "$pkgdir"
install -Dm 0664 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
rm -rf "$pkgdir/usr/bin"