summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122017-02-04 11:02:52 +0100
committerwillemw122017-02-04 11:02:52 +0100
commitc288e8175aef8e659b379228ddce97e1036d2eb2 (patch)
tree270dfecc5ddce8a237bafca612f303a444ef0558
parent31fe4445d80b2836885c70fcb8ec65482dc7b41a (diff)
downloadaur-c288e8175aef8e659b379228ddce97e1036d2eb2.tar.gz
Remove libunity. Patch .desktop files
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a76b435a92e..fd70beb2e67b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vocal-git
pkgdesc = Podcast Client for the Modern Desktop
- pkgver = 2.0.5.beta.r25.geb41af0
+ pkgver = 2.0.10.beta.r0.g395cdbb
pkgrel = 1
url = http://www.vocalproject.net
arch = i686
@@ -18,7 +18,6 @@ pkgbase = vocal-git
depends = clutter-gtk
depends = clutter-gst
depends = webkit2gtk
- optdepends = libunity: Unity shell (make dependency)
provides = vocal
conflicts = vocal
source = vocal::git://github.com/vocalapp/vocal.git
diff --git a/PKGBUILD b/PKGBUILD
index 8fda29b184bc..5c4f82675b54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=vocal
pkgname=$_pkgname-git
-pkgver=2.0.5.beta.r25.geb41af0
+pkgver=2.0.10.beta.r0.g395cdbb
pkgrel=1
pkgdesc="Podcast Client for the Modern Desktop"
arch=('i686' 'x86_64')
@@ -13,9 +13,9 @@ url="http://www.vocalproject.net"
license=('GPL3')
depends=('libnotify' 'libxml2' 'granite' 'gtk3' 'gstreamer' 'sqlite' 'clutter-gtk' 'clutter-gst' 'webkit2gtk')
makedepends=('git' 'vala' 'cmake')
-optdepends=('libunity: Unity shell (make dependency)')
provides=($_pkgname)
conflicts=($_pkgname)
+#source=($_pkgname::git://github.com/needle-and-thread/vocal.git)
source=($_pkgname::git://github.com/vocalapp/vocal.git)
md5sums=('SKIP')
@@ -29,16 +29,23 @@ prepare() {
# Use newer version of webkit2gtk
sed -i 's/webkit2gtk-3.0/webkit2gtk-4.0/g' CMakeLists.txt
+
+ # Patch
+ cd data
+ mv com.github.{needle-and-thread,vocalapp}.vocal.desktop
+ mv com.github.needle-and-thread.vocal.appdata.xml com.github.vocalapp.vocal.desktop.appdata.xml
}
build() {
cd $_pkgname
- cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr # -DGSETTINGS_LOCALINSTALL=1 -DGSETTINGS_COMPILE=1
make
}
package() {
- cd $_pkgname
+ cd $_pkgname/build
make DESTDIR="$pkgdir/" install
}