summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-20 15:59:03 -0700
committerMark Wagie2024-01-20 15:59:03 -0700
commitc28e059c8456635441d96e355ca4788bb9fe275e (patch)
treeb4402f1bee941be9f488903fe70d52beea3a0c9f
parent235d41f7b08e3180155f06e2a2cf2bfb5e1ccb63 (diff)
downloadaur-c28e059c8456635441d96e355ca4788bb9fe275e.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43400defe41e..8872e4db92b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = gnome-shell-extension-weather-in-the-clock-git
pkgrel = 1
url = https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
depends = gnome-shell<=1:44.6
depends = gnome-weather
diff --git a/PKGBUILD b/PKGBUILD
index 965a77ce636a..e1938bfbc7b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=gnome-shell-extension-weather-in-the-clock-git
+_uuid=weatherintheclock@JasonLG1979.github.io
pkgver=r27.38ba360
pkgrel=1
pkgdesc="Display the current Weather in the Clock."
arch=('any')
url="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('gnome-shell<=1:44.6' 'gnome-weather')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+$url.git")
+source=("git+https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- _uuid='weatherintheclock@JasonLG1979.github.io'
-
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
install -d "$pkgdir/usr/share/gnome-shell/extensions"
cp -a $_uuid "$pkgdir/usr/share/gnome-shell/extensions"
}