summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rheinsberg2022-05-19 09:27:17 +0200
committerDavid Rheinsberg2022-05-19 09:27:17 +0200
commitc29663e40bddbd40bb1d8f917d288ce251196c93 (patch)
treee60f561fd5a09420e22f3dc1f4fd3c0bc8242d0b
parent00ea1e00d0c458628e82c19bcdec051face206f5 (diff)
downloadaur-c29663e40bddbd40bb1d8f917d288ce251196c93.tar.gz
dbus-broker-git: use more descriptive reflog
This changes the version number from: $ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" r1502.5d475cf to: $ git describe --long --tags | sed 's/^v//;s/-/./g' 31.14.g5d475cf We now have the release-version leading the version-number, making it much easier to deduce the base branch. It is then followed by number of patches on top, as well as the git-sha for identification. Suggested-by: ms178 Signed-off-by: David Rheinsberg <david.rheinsberg@gmail.com>
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b41abb774c1..8931a2b5ede3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,7 @@ sha256sums=('SKIP'
pkgver() {
cd $pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/-/./g'
}
prepare() {