summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimttmy2015-08-09 11:35:39 +0100
committertimttmy2015-08-09 11:35:39 +0100
commitc2b1ee8fbe63207c36c2157ee023c6840681b7ac (patch)
tree1133981e42fd573cec99aba40274d99f6d705b48
downloadaur-c2b1ee8fbe63207c36c2157ee023c6840681b7ac.tar.gz
Initial
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD54
-rw-r--r--blather.desktop8
-rw-r--r--blather.install21
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27e393eb2df4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = blather-git
+ pkgdesc = Python application for speech recognition using pocketsphinx and gstreamer. - latest git revision
+ pkgver = 20150809
+ pkgrel = 1
+ url = https://gitorious.org/blather
+ install = blather.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python2
+ depends = pocketsphinx
+ depends = gstreamer
+ depends = gstreamer0.10-python
+ optdepends = pyside
+ optdepends = pygtk
+ provides = blather
+ source = blather.desktop
+ md5sums = efcf40264e5d4cccea06ad7676ab2393
+
+pkgname = blather-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19b9ff2ce404
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: timttmy <marshall\\dot//cleave\\at//tiscali\\dot//co\\dot//uk>
+
+pkgname='blather-git'
+_pkgname=blather
+pkgver=20150809
+pkgrel=1
+pkgdesc="Python application for speech recognition using pocketsphinx and gstreamer. - latest git revision"
+arch=('any')
+url="https://gitorious.org/blather"
+license=('GPL3')
+depends=('python2' 'pocketsphinx' 'gstreamer' 'gstreamer0.10-python')
+provides=('blather')
+install=blather.install
+source=($_pkgname.desktop)
+md5sums=('efcf40264e5d4cccea06ad7676ab2393')
+optdepends=('pyside' 'pygtk')
+makedepends=('git')
+
+
+
+_gitroot="git://gitorious.org/blather/blather.git"
+
+_gitname="blather"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+ cd "$srcdir/$_gitname"
+
+
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/blather" || return 1
+ mkdir -p "$pkgdir/usr/bin/" || return 1
+ mkdir -p "$pkgdir/usr/share/pixmaps/" || return 1
+ rm -r "$srcdir/$_gitname/.git" && cp -a ./ "$pkgdir/usr/share/" || return 1
+ ln -sf /usr/share/blather/Blather.py "$pkgdir/usr/bin/Blather" || return 1
+ install -m 644 $srcdir/$_pkgname/assets/blather.png "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 $startdir/$_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ python2 -m compileall "$pkgdir/usr/share/Blather"
+
+
+ }
diff --git a/blather.desktop b/blather.desktop
new file mode 100644
index 000000000000..a2607eef3acb
--- /dev/null
+++ b/blather.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Exec=Blather
+Name=Blather speech recognition.
+Type=Application
+Terminal=true
+Icon=blather.png
+Caption=Blather speech recognition.
+Categories=Application;Other
diff --git a/blather.install b/blather.install
new file mode 100644
index 000000000000..008fbbe925f8
--- /dev/null
+++ b/blather.install
@@ -0,0 +1,21 @@
+post_install() {
+echo ""
+echo "Blather is a speech recognizer that will run commands when a user speaks preset sentences."
+echo ""
+echo "Requirements"
+echo "1. pocketsphinx"
+echo "2. gstreamer (and what ever plugin has pocket sphinx support)"
+echo "3. pyside (only required for the Qt based UI)"
+echo "4. pygtk (only required for the Gtk based UI)"
+echo ""
+echo ""
+echo "Usage"
+echo "See the README.md in /usr/share/blather/"
+echo ""
+echo "READ THE README.md IN /usr/share/blather/ !!!"
+}
+
+post_upgrade() {
+ post_install
+}
+