summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornyllewin2024-03-28 23:32:48 +0100
committernyllewin2024-03-28 23:32:48 +0100
commitc2cd1f739fc013fed8291993a7204515ea33f2aa (patch)
tree9824213b2ddc5ad00bbb1a586debb0811cec14a0
parentd15403fba12f255969d2d50a552e546f635bf3d2 (diff)
downloadaur-c2cd1f739fc013fed8291993a7204515ea33f2aa.tar.gz
applied devmode fix/patch from comments
-rw-r--r--PKGBUILD6
-rw-r--r--PathOfBuilding-force-disable-devmode.patch22
2 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb9abb83d473..d6e7f5d685f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: bcareil <baptiste.careil@gmail.com>
pkgname='path-of-building-community-git'
-pkgrel=1
+pkgrel=2
pkgdesc="An offline build planner for Path of Exile using PoBFrontend, LocalIdentity's fork"
arch=('x86_64')
url='https://github.com/PathOfBuildingCommunity/PathOfBuilding'
license=('MIT')
-pkgver=2.41.0.1bed7eb
+pkgver=2.41.1.r7815.62.517
depends=('zlib' 'qt6-base' 'luajit' 'libgl' 'curl' 'ttf-liberation' 'ttf-bitstream-vera')
makedepends=('meson' 'ninja' 'unzip' 'rsync' 'git')
@@ -30,7 +30,7 @@ sha256sums=(
'6d21872a2b2bdbfaebb20de5cac28ac402316e5314c97a89049320ff13c2f622'
'30118e22623b645a5e2cc81240fcf36d5189613383a09d1225aa3a76f7eba245'
'9dbc8802b74ceed78f1a6ba1d5b90251f5ae7f9a8cf5497426e4a35001112fcd'
- 'cd46475a1bc62240e03abb6b385b0c9b0b911ad828219fd31f98f7742807f935'
+ 'cab009c706747d45f654a3afc2a3cde3a650eb84cd4230353b40df5a4ad1d68b'
'2467d10c7b5e201e337ba334a829e293a07027251bcda2b1f39774a62e8ff194'
'a64198061f60168ec07df33c37948e343eced7eeafe574cc20bdcf3a1d480cbc'
'079eff1a5e74cb6d776723f7c3d36349e426edaa332a8177ff8f5e78af56cf64'
diff --git a/PathOfBuilding-force-disable-devmode.patch b/PathOfBuilding-force-disable-devmode.patch
index 6f697bb1d50b..d61c38940a4a 100644
--- a/PathOfBuilding-force-disable-devmode.patch
+++ b/PathOfBuilding-force-disable-devmode.patch
@@ -1,17 +1,17 @@
diff --git a/src/Launch.lua b/src/Launch.lua
-index 0673314..39800ae 100644
+index 0775ec4dc..a5113655c 100644
--- a/src/Launch.lua
+++ b/src/Launch.lua
-@@ -51,7 +51,7 @@ function launch:OnInit()
+@@ -56,7 +56,7 @@ function launch:OnInit()
if localManXML and not self.versionBranch and not self.versionPlatform then
-- Looks like a remote manifest, so we're probably running from a repository
-- Enable dev mode to disable updates and set user path to be the script path
- self.devMode = true
+ self.devMode = false
end
- RenderInit()
- ConPrintf("Loading main script...")
-@@ -286,6 +286,8 @@ function launch:ApplyUpdate(mode)
+ local installedFile = io.open("installed.cfg", "r")
+ if installedFile then
+@@ -324,6 +324,8 @@ function launch:ApplyUpdate(mode)
end
function launch:CheckForUpdate(inBackground)
@@ -20,7 +20,7 @@ index 0673314..39800ae 100644
if self.updateCheckRunning then
return
end
-@@ -302,6 +304,7 @@ function launch:CheckForUpdate(inBackground)
+@@ -340,6 +342,7 @@ function launch:CheckForUpdate(inBackground)
self.updateCheckRunning = true
end
update:close()
@@ -29,13 +29,13 @@ index 0673314..39800ae 100644
function launch:ShowPrompt(r, g, b, str, func)
diff --git a/src/Modules/Main.lua b/src/Modules/Main.lua
-index 1af88e0..683fc33 100644
+index 39385efab..144e072ef 100644
--- a/src/Modules/Main.lua
+++ b/src/Modules/Main.lua
-@@ -42,7 +42,7 @@ function main:Init()
- self.modes["LIST"] = LoadModule("Modules/BuildList")
- self.modes["BUILD"] = LoadModule("Modules/Build")
-
+@@ -73,7 +73,7 @@ function main:Init()
+ if not ignoreBuild then
+ self:SetMode("BUILD", false, "Unnamed build")
+ end
- if launch.devMode or (GetScriptPath() == GetRuntimePath() and not launch.installedMode) then
+ if launch.devMode and (GetScriptPath() == GetRuntimePath() and not launch.installedMode) then
-- If running in dev mode or standalone mode, put user data in the script path