summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422022-08-16 05:47:29 +0000
committerSkycoder422022-08-16 05:47:29 +0000
commitc2e5f7b85b397cfffdf0ac2a62ab3815f919b6e3 (patch)
treea2ba3ca31a43fb7cfea0d70ac415966f561d11e3
parent469970b308347d33c2449f2002ab0e841adacf92 (diff)
downloadaur-c2e5f7b85b397cfffdf0ac2a62ab3815f919b6e3.tar.gz
Update paxchange to version 1.0.0
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG.md10
-rw-r--r--PKGBUILD11
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6033699ebfeb..acc7c110de00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = paxchange
pkgdesc = Simple dart script to passively synchronize installed pacman packages between systems.
- pkgver = 0.1.2
+ pkgver = 1.0.0
pkgrel = 1
epoch = 2
url = https://github.com/Skycoder42/paxchange
@@ -14,7 +14,8 @@ pkgbase = paxchange
makedepends = dart<3.0.0
depends = pacman
options = !strip
- source = paxchange-0.1.2.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v0.1.2.tar.gz
- b2sums = 814b80df62a4af65c68ba4c0eba675030c637d284aba5e9f101ec087005a96e0fcbf350b2387b480e91a5941cb6abff2035b483338596b8a7144ab57cbd6e54c
+ backup = etc/paxchange.json
+ source = paxchange-1.0.0.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v1.0.0.tar.gz
+ b2sums = 0d9ba738502f3e6e6483a5438251d332e97883a08c840e6043831f8b16d85f12793eefe3db8a3d336ccaaa989580381c20a34ef36c67593a8fc98d701164fd71
pkgname = paxchange
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 97b9b3dc2ef4..eb99e8891d19 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,11 +4,15 @@ All notable changes to this project will be documented in this file.
The format is based on Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to Semantic Versioning](https://semver.org/spec/v2.0.0.html).
-## 1.0.2
+## 1.0.0
+- Rename default command to `update`
+- Add `review` command to review detected package changes
+
+## 0.1.2
- Small fixups, repair AUR package
-## 1.0.1
+## 0.1.1
- Use dart_test_tools aur workflow template
-## 1.0.0
+## 0.1.0
- Initial release
diff --git a/PKGBUILD b/PKGBUILD
index 224d4f700343..7caea704e79b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Skycoder42 <Skycoder42@users.noreply.github.com>
pkgname='paxchange'
pkgdesc='Simple dart script to passively synchronize installed pacman packages between systems.'
-pkgver='0.1.2'
+pkgver='1.0.0'
pkgrel=1
epoch=2
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -9,10 +9,11 @@ url='https://github.com/Skycoder42/paxchange'
license=('BSD')
depends=('pacman')
makedepends=('dart>=2.17.0' 'dart<3.0.0')
-_pkgdir='paxchange-0.1.2'
-source=("$_pkgdir.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v0.1.2.tar.gz")
-b2sums=('814b80df62a4af65c68ba4c0eba675030c637d284aba5e9f101ec087005a96e0fcbf350b2387b480e91a5941cb6abff2035b483338596b8a7144ab57cbd6e54c')
+_pkgdir='paxchange-1.0.0'
+source=("$_pkgdir.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v1.0.0.tar.gz")
+b2sums=('0d9ba738502f3e6e6483a5438251d332e97883a08c840e6043831f8b16d85f12793eefe3db8a3d336ccaaa989580381c20a34ef36c67593a8fc98d701164fd71')
changelog='CHANGELOG.md'
+backup=('etc/paxchange.json')
options=('!strip')
prepare() {
@@ -35,6 +36,8 @@ check() {
package() {
cd "$_pkgdir"
install -D -m755 'bin/paxchange' "$pkgdir/usr/bin/"'paxchange'
+ install -D -m644 'deploy/aur/config.json' "$pkgdir/etc/paxchange.json"
+ install -D -m644 'deploy/aur/paxchange.hook' "$pkgdir/usr/share/libalpm/hooks/paxchange.hook"
install -D -m644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/"'LICENSE'
}