summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Maftei2020-06-03 09:00:04 +0300
committerDan Maftei2020-06-03 09:00:04 +0300
commitc2f2c8eb0d8ccc93b9db6f667119bc1054023c35 (patch)
treea75b7bbfd6bdbbd592959385a81de12dd70ce4bf
parentbc7fdf883e6fab715f2f016a439cd2cc2ae0b439 (diff)
downloadaur-c2f2c8eb0d8ccc93b9db6f667119bc1054023c35.tar.gz
Upstream checksum changed.
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4348cb9d62fb..598d2236d18a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,9 +35,14 @@ md5sums=('92d6aa6442c3e67571b4494553b0d180')
build() {
cd "molden$pkgver"
- # Patch Makefile for surf utility to reflect the
- # replacement of missing makedepend
+ # Patch Makefile for surf utility to reflect
+ # the replacement of missing makedepend
sed -i 's/@.*makedepend.*$/@ \$(CC) \$(INCLUDE) -M \$(SRCS) \> makedep/' surf/Makefile
+
+ # Patch to compile with gfortran 10
+ # Contributed by Panadestein on 5/31/2020
+ sed -i 's/FFLAGS = -g ${AFLAG}/& -fallow-argument-mismatch/g' makefile
+ sed -i 's/FFLAGS = -c -g -ffast-math -funroll-loops -O3/& -fallow-argument-mismatch/g' ambfor/makefile
make
}