summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2020-07-30 21:29:10 +0200
committerMarc-Olivier Barre2020-07-30 21:29:10 +0200
commitc3017be65c9fb948df9e56ee9e2b0724ea422aeb (patch)
tree7ecb1190c9d9d070a179d46781b0555939478b83
parente50ddbde75980d55d5b81415c3416d4e2699df46 (diff)
downloadaur-c3017be65c9fb948df9e56ee9e2b0724ea422aeb.tar.gz
Update to 1.7.0 and fix the lpthread build issue.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--libASICamera_pthread_fix.diff32
-rw-r--r--oacapture-slash-lib.diff11
4 files changed, 57 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e01af384582e..e839183a03f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = oacapture
pkgdesc = A planetary imaging application using Qt5
- pkgver = 1.5.0
- pkgrel = 2
+ pkgver = 1.7.0
+ pkgrel = 1
url = http://www.openastroproject.org/oacapture/
arch = i686
arch = x86_64
@@ -15,8 +15,12 @@ pkgbase = oacapture
optdepends = fxload: support for QHY5 cameras
provides = oacapture
conflicts = oacapture-git
- source = https://github.com/openastroproject/openastro/archive/v1.5.0.tar.gz
- sha256sums = 1b3fc328cfa9e64ef6c5f51d2aa17196f636f8171a15e916f322a0875114bc31
+ source = https://github.com/openastroproject/openastro/archive/v1.7.0.tar.gz
+ source = oacapture-slash-lib.diff
+ source = libASICamera_pthread_fix.diff
+ sha256sums = 898fbb533dddc36369764198faf480f11265fb535a34f63f15b132eb8a718cd3
+ sha256sums = 813e80ef718e0e9887c5293ef435b1cff43d03ae8c2bb6a2d53f0bbbf4a284f2
+ sha256sums = 56a86e3ad5a46eb25fce7209e9242b51da6d1d56facedbfe7f062395758b1621
pkgname = oacapture
diff --git a/PKGBUILD b/PKGBUILD
index 6ae06bee3ce1..e613bb810f30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=oacapture
-pkgver=1.5.0
-pkgrel=2
+pkgver=1.7.0
+pkgrel=1
pkgdesc="A planetary imaging application using Qt5"
provides=("oacapture")
conflicts=("oacapture-git")
@@ -10,11 +10,13 @@ depends=('qt5-base' 'qt5-tools' 'cfitsio' 'autoconf-archive' 'sdl' 'libdc1394')
url="http://www.openastroproject.org/oacapture/"
optdepends=('fxload: support for QHY5 cameras')
-source=("https://github.com/openastroproject/openastro/archive/v${pkgver}.tar.gz")
-sha256sums=("1b3fc328cfa9e64ef6c5f51d2aa17196f636f8171a15e916f322a0875114bc31")
+source=("https://github.com/openastroproject/openastro/archive/v${pkgver}.tar.gz" "oacapture-slash-lib.diff" "libASICamera_pthread_fix.diff")
+sha256sums=("898fbb533dddc36369764198faf480f11265fb535a34f63f15b132eb8a718cd3" "813e80ef718e0e9887c5293ef435b1cff43d03ae8c2bb6a2d53f0bbbf4a284f2" "56a86e3ad5a46eb25fce7209e9242b51da6d1d56facedbfe7f062395758b1621")
build() {
cd "openastro-${pkgver}"
+ patch -Np1 < ${srcdir}/oacapture-slash-lib.diff
+ patch -Np1 < ${srcdir}/libASICamera_pthread_fix.diff
./bootstrap
./configure --prefix=/usr
make
diff --git a/libASICamera_pthread_fix.diff b/libASICamera_pthread_fix.diff
new file mode 100644
index 000000000000..8cc399cadf38
--- /dev/null
+++ b/libASICamera_pthread_fix.diff
@@ -0,0 +1,32 @@
+diff --git a/oacapture/Makefile.am b/oacapture/Makefile.am
+index cab7457..63214cf 100644
+--- a/oacapture/Makefile.am
++++ b/oacapture/Makefile.am
+@@ -68,8 +68,9 @@ oacapture_LDADD = \
+ $(LIBUSB_LIBS) \
+ $(LIBASI2_LIBS) \
+ $(LIBZWOFW_LIBS) \
+- $(LIBGPHOTO2_LIBS) \
+- $(OSX_FRAMEWORKS)
++ $(LIBGPHOTO2_LIBS) \
++ $(OSX_FRAMEWORKS) \
++ -lpthread
+
+ WARNINGS = -g -O -Wall -Werror -Wpointer-arith -Wuninitialized -Wsign-compare -Wformat-security -Wno-pointer-sign $(OSX_WARNINGS)
+
+diff --git a/oalive/Makefile.am b/oalive/Makefile.am
+index f5bf5e2..dd1b1b3 100644
+--- a/oalive/Makefile.am
++++ b/oalive/Makefile.am
+@@ -64,8 +64,9 @@ oalive_LDADD = \
+ $(LIBUSB_LIBS) \
+ $(LIBASI2_LIBS) \
+ $(LIBZWOFW_LIBS) \
+- $(LIBGPHOTO2_LIBS) \
+- $(OSX_FRAMEWORKS)
++ $(LIBGPHOTO2_LIBS) \
++ $(OSX_FRAMEWORKS) \
++ -lpthread
+
+ WARNINGS = -g -O -Wall -Werror -Wpointer-arith -Wuninitialized -Wsign-compare -Wformat-security -Wno-pointer-sign $(OSX_WARNINGS)
+
diff --git a/oacapture-slash-lib.diff b/oacapture-slash-lib.diff
new file mode 100644
index 000000000000..c1aea55306a1
--- /dev/null
+++ b/oacapture-slash-lib.diff
@@ -0,0 +1,11 @@
+diff --git a/udev/Makefile.am b/udev/Makefile.am
+index 8b7d790..e5e58ce 100644
+--- a/udev/Makefile.am
++++ b/udev/Makefile.am
+@@ -31,5 +31,5 @@ RULESFILES = 70-altair-cameras.rules 70-atik.rules 70-celestron-camera.rules \
+ 70-tis-cameras.rules 70-tis-cameras-uvc.rules \
+ 70-touptek-cameras.rules 70-xagyl-ftdi.rules 85-qhy-cameras.rules
+
+-udevrulesdir = ${sysconfdir}/../lib/udev/rules.d
++udevrulesdir = ${sysconfdir}/../usr/lib/udev/rules.d
+ udevrules_DATA = $(RULESFILES)