summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-12-15 09:25:34 -0700
committerMark Wagie2021-12-15 09:25:34 -0700
commitc309906981b95000ad519adc80f14238b20937bd (patch)
tree65d37bd640d75beda32447369c1421348b9e6f14
parentbcaddff1ff50154f65499405d4381c3b2e3c348e (diff)
downloadaur-c309906981b95000ad519adc80f14238b20937bd.tar.gz
use realh's fork
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e0c420919a..e90e419f788b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = gnome-shell-extension-multi-monitors-add-on-git
pkgdesc = Adds panels and thumbnails for additional monitors.
- pkgver = 23.r0.g0cec99d
- pkgrel = 4
- url = https://github.com/spin83/multi-monitors-add-on
+ pkgver = 19.r40.g0b54630
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/realh/multi-monitors-add-on
arch = any
license = GPL2
makedepends = git
depends = gnome-shell
provides = gnome-shell-extension-multi-monitors-add-on
conflicts = gnome-shell-extension-multi-monitors-add-on
- source = git+https://github.com/spin83/multi-monitors-add-on.git
- source = https://github.com/spin83/multi-monitors-add-on/pull/163.patch
+ source = git+https://github.com/realh/multi-monitors-add-on.git
sha256sums = SKIP
- sha256sums = e157f4ed3afec752c5ccd623efbc3ddb9e8971ab20606adb8f1e0133da7bbdbe
pkgname = gnome-shell-extension-multi-monitors-add-on-git
diff --git a/PKGBUILD b/PKGBUILD
index 041d7029a101..8c69c765b146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,46 +3,38 @@
# Contributor: smcdougall <simon at sjmcdougall dot com>
pkgname=gnome-shell-extension-multi-monitors-add-on-git
_pkgname=multi-monitors-add-on
-pkgver=23.r0.g0cec99d
-pkgrel=4
+pkgver=19.r40.g0b54630
+pkgrel=1
+epoch=1
pkgdesc="Adds panels and thumbnails for additional monitors."
arch=('any')
-url="https://github.com/spin83/multi-monitors-add-on"
+url="https://github.com/realh/multi-monitors-add-on"
license=('GPL2')
depends=('gnome-shell')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/spin83/multi-monitors-add-on.git'
- 'https://github.com/spin83/multi-monitors-add-on/pull/163.patch')
-sha256sums=('SKIP'
- 'e157f4ed3afec752c5ccd623efbc3ddb9e8971ab20606adb8f1e0133da7bbdbe')
+source=('git+https://github.com/realh/multi-monitors-add-on.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/$_pkgname"
-
- # Added Partial Support for Gnome 41
- patch -Np1 -i $srcdir/163.patch
-}
-
package() {
cd "$srcdir/$_pkgname"
_uuid="$_pkgname@spin83"
_schema="org.gnome.shell.extensions.$_pkgname.gschema.xml"
- rm "$_uuid/$_pkgname.pot"
-
install -d "$pkgdir/usr/share/gnome-shell/extensions/"
cp -a "$_uuid/" "$pkgdir/usr/share/gnome-shell/extensions/"
- install -d "$pkgdir/usr/share/glib-2.0/schemas/"
- ln -s "/usr/share/gnome-shell/extensions/$_uuid/schemas/$_schema" \
+ install -Dm644 "$_uuid/schemas/org.gnome.shell.extensions.$_pkgname.gschema.xml" -t \
"$pkgdir/usr/share/glib-2.0/schemas/"
+
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/schemas/"
+ rm "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/$_pkgname.pot"
}