summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoohbah2015-08-15 02:24:39 +0000
committerBoohbah2015-08-15 02:24:39 +0000
commitc312510c32d506471ce10367deb8f97d76444462 (patch)
treed9c2fcb9f39b470379452a48aacec546afe1c887
downloadaur-c312510c32d506471ce10367deb8f97d76444462.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--add-includes.patch14
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79d3861be70b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = oneko
+ pkgdesc = A modified version of oneko. KINOMOTO Sakura chases around your mouse cursor.
+ pkgver = 1.2.sakura.5
+ pkgrel = 1
+ url = http://www.daidouji.com/oneko/
+ arch = i686
+ arch = x86_64
+ license = Unknown
+ makedepends = libxext
+ depends = libx11
+ source = http://www.daidouji.com/oneko/distfiles/oneko-1.2.sakura.5.tar.gz
+ source = add-includes.patch
+ md5sums = 456b318fa6e61431bf4f0a42b110014a
+ md5sums = fae2e02a36ececa2bcf13e08afa2bd95
+
+pkgname = oneko
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d3dda692be7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Boohbah <boohbah at gmail.com>
+
+pkgname=oneko
+pkgver=1.2.sakura.5
+pkgrel=1
+pkgdesc="A modified version of oneko. KINOMOTO Sakura chases around your mouse cursor."
+arch=('i686' 'x86_64')
+url="http://www.daidouji.com/oneko/"
+license=('Unknown')
+depends=('libx11')
+makedepends=('libxext')
+source=("http://www.daidouji.com/oneko/distfiles/$pkgname-$pkgver.tar.gz"
+ 'add-includes.patch')
+md5sums=('456b318fa6e61431bf4f0a42b110014a'
+ 'fae2e02a36ececa2bcf13e08afa2bd95')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/add-includes.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ gcc -lm -lX11 -o oneko oneko.c
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 oneko "$pkgdir/usr/bin/oneko"
+ install -Dm644 oneko.man "$pkgdir/usr/share/man/man6/oneko.6"
+ mkdir "$pkgdir/usr/share/oneko"
+ cp -a bitmaps bitmasks cursors "$pkgdir/usr/share/oneko"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/add-includes.patch b/add-includes.patch
new file mode 100644
index 000000000000..007960efe874
--- /dev/null
+++ b/add-includes.patch
@@ -0,0 +1,14 @@
+diff --git a/oneko.c b/oneko.c
+index d2b81fe..b7e5e49 100644
+--- a/oneko.c
++++ b/oneko.c
+@@ -6,6 +6,9 @@
+ static char rcsid[] = "$Header: /home/sun/unix/kato/xsam/oneko/oneko.c,v 1.5 90/10/19 21:25:16 kato Exp $";
+ #endif
+
++#include <X11/Xlib.h>
++#include <math.h>
++
+ #include "oneko.h"
+ #include "patchlevel.h"
+ /*