summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYellowsink2021-02-20 00:20:33 +0000
committerYellowsink2021-02-20 00:20:33 +0000
commitc3209d4d342b3a3b04fefbc6c6786499420a0e5c (patch)
tree8b75dd7dcd4a64604f435093e6c7f6ca296de27d
parentc7ea23457f73f175e234c27aceb81e6ae1ee71c2 (diff)
downloadaur-c3209d4d342b3a3b04fefbc6c6786499420a0e5c.tar.gz
Fix permissions for portable save folder
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88252aafbab0..3a947a766b36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = discordrichpresencepresets-git
pkgdesc = A GUI tool to set and switch between Discord Rich Presences
pkgver = avalonia.v0.1.beta.r17.3045abe
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/cainy-a/DiscordRichPresencePresets
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 3d1d582494cb..d8c34ab249d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="discordrichpresencepresets"
pkgname="${_pkgname}-git"
pkgver=avalonia.v0.1.beta.r17.3045abe
-pkgrel=2
+pkgrel=3
pkgdesc="A GUI tool to set and switch between Discord Rich Presences"
arch=('x86_64')
url="https://github.com/cainy-a/DiscordRichPresencePresets"
@@ -85,4 +85,11 @@ package() {
install -Dm 644 "launch.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
# install launch script
install -Dm 755 "launch.sh" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Only root can write to the install directory.
+ # For portable saves this is an issue. (though you shouldn't use portable with the AUR version :P)
+ # However custom save location uses portable settings save, causing settings to reset each relaunch
+ # This creates the data dir ahead of time and gives all users write access.
+ mkdir "${pkgdir}/usr/lib/${_pkgname}/data/"
+ chmod 777 "${pkgdir}/usr/lib/${_pkgname}/data/"
}