summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-02-16 17:33:59 -0800
committerxiota2024-02-16 18:03:54 -0800
commitc33afbc4a83d614045e6c55d080421a4225ff790 (patch)
treea5290d3c0eb92aedf8f531140dc5e99861615dfd
parentf633155533808398565b6a0c18eb7e3cbe472ed5 (diff)
downloadaur-c33afbc4a83d614045e6c55d080421a4225ff790.tar.gz
13.13
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff63c491a6f1..7e03aa00dfbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,28 @@
pkgbase = debhelper
pkgdesc = A collection of programs that can be used in a debian/rules file to automate common tasks
- pkgver = 13.11.10
+ pkgver = 13.13
pkgrel = 1
url = https://salsa.debian.org/debian/debhelper
arch = any
- license = GPL2
- license = GPL3
+ license = GPL-2.0-or-later
makedepends = git
makedepends = po4a
+ depends = dpkg
depends = perl-pod-parser
optdepends = dh-make: convert source archives into Debian package source
provides = dh-strip-nondeterminism
conflicts = dh-strip-nondeterminism
- source = git+https://salsa.debian.org/debian/debhelper.git#tag=debian/13.11.10
+ source = git+https://salsa.debian.org/debian/debhelper.git#tag=debian/13.13
source = dh_strip_nondeterminism::https://salsa.debian.org/reproducible-builds/strip-nondeterminism/-/raw/master/bin/dh_strip_nondeterminism
sha256sums = SKIP
sha256sums = SKIP
pkgname = debhelper
+ depends = dpkg
depends = perl-pod-parser
depends = binutils
- depends = dpkg
depends = file
- depends = html2text
depends = man-db
+ depends = python-html2text
depends = strip-nondeterminism
depends = po-debconf
diff --git a/PKGBUILD b/PKGBUILD
index e98959c9188d..9c5fc8d5b366 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,26 @@
# Contributor: Charles Pigott <charlespigott@googlemail.com>
# Contributor: Andrei "Garoth" Thorp <garoth "at the nice" gmail "dot" com>
+## options
+: ${_build_git:=false}
+
+unset _pkgtype
+[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git"
+
+## basic info
_pkgname="debhelper"
-pkgname="$_pkgname"
-pkgver=13.11.10
+pkgname="$_pkgname${_pkgtype:-}"
+pkgver=13.13
pkgrel=1
pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
url="https://salsa.debian.org/debian/debhelper"
-license=('GPL2' 'GPL3')
+license=('GPL-2.0-or-later')
arch=('any')
_url_dh_strip_nondeterminism="https://salsa.debian.org/reproducible-builds/strip-nondeterminism"
depends=(
+ 'dpkg'
'perl-pod-parser'
)
makedepends=(
@@ -26,8 +34,8 @@ optdepends=(
'dh-make: convert source archives into Debian package source'
)
-if [ x"$pkgname" == x"$_pkgname" ] ; then
- # normal package
+if [ "${_build_git::1}" != "t" ] ; then
+ # stable package
_pkgsrc="$_pkgname"
source=("git+$url.git#tag=debian/${pkgver%%.r*}")
sha256sums=('SKIP')
@@ -56,6 +64,13 @@ conflicts+=("dh-strip-nondeterminism")
source+=("dh_strip_nondeterminism"::"$_url_dh_strip_nondeterminism/-/raw/master/bin/dh_strip_nondeterminism")
sha256sums+=('SKIP')
+prepare() {
+ cd "$_pkgsrc"
+
+ # prevent unicode error
+ rm "man/po4a/po"/*.po
+}
+
build() {
cd "$_pkgsrc"
make
@@ -64,10 +79,9 @@ build() {
package() {
depends+=(
'binutils'
- 'dpkg'
'file'
- 'html2text'
'man-db'
+ 'python-html2text'
'strip-nondeterminism'
# AUR
@@ -75,8 +89,8 @@ package() {
)
cd "$_pkgsrc"
- make DESTDIR="${pkgdir:?}" install
- install -Dm755 "${srcdir:?}/dh_strip_nondeterminism" -t "${pkgdir:?}/usr/bin"
+ make DESTDIR="$pkgdir" install
+ install -Dm755 "$srcdir/dh_strip_nondeterminism" -t "$pkgdir/usr/bin"
}
# vim:set ts=2 sw=2 et: