summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornullgemm2020-07-28 17:49:48 +0200
committernullgemm2020-07-28 17:49:48 +0200
commitc34d4ac5a798ac7fd7a7e6a6d230732d61c9231b (patch)
tree59879317195e6ec56de96bf384aae6b440fd7fbe
parent4574d69fb63d53bbfa7078b2ac026a69faac1216 (diff)
downloadaur-c34d4ac5a798ac7fd7a7e6a6d230732d61c9231b.tar.gz
update to v0.5.2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
2 files changed, 55 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38ad5f5b6741..281a894d7234 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,30 @@
pkgbase = ly
pkgdesc = TUI display manager
- pkgver = 0.5.0
- pkgrel = 1
- url = https://github.com/cylgom/ly
+ pkgver = 0.5.2
+ pkgrel = 2
+ url = https://github.com/nullgemm/ly
arch = i686
arch = x86_64
+ arch = aarch64
license = custom:WTFPL
- makedepends = unzip
+ makedepends = git
depends = pam
depends = xorg-xauth
conflicts = ly-git
conflicts = python-ly-git
- source = https://github.com/cylgom/ly/releases/download/v0.5.0/ly_0.5.0.zip
- md5sums = ff30840e9427343cb4a537095647d811
+ backup = etc/ly/config.ini
+ source = git+https://github.com/nullgemm/ly.git#tag=v0.5.2
+ source = git+https://github.com/nullgemm/argoat.git
+ source = git+https://github.com/nullgemm/configator.git
+ source = git+https://github.com/nullgemm/ctypes.git
+ source = git+https://github.com/nullgemm/dragonfail.git
+ source = git+https://github.com/nullgemm/termbox_next.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = ly
diff --git a/PKGBUILD b/PKGBUILD
index 53bdc36d5639..93def97d6996 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,45 @@
-# Maintainer: cylgom <cylgom@gmail.com>
+# Maintainer: nullgemm <nullgemm@mailbox.org>
pkgname=ly
-pkgver=0.5.0
-pkgrel=1
+pkgver=0.5.2
+pkgrel=2
pkgdesc="TUI display manager"
-arch=('i686' 'x86_64')
-url="https://github.com/cylgom/ly"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/nullgemm/ly"
license=('custom:WTFPL')
-makedepends=('unzip')
+makedepends=('git')
depends=('pam' 'xorg-xauth')
conflicts=('ly-git' 'python-ly-git')
-source=('https://github.com/cylgom/ly/releases/download/v0.5.0/ly_0.5.0.zip')
-md5sums=('ff30840e9427343cb4a537095647d811')
+backup=('etc/ly/config.ini')
+source=("git+https://github.com/nullgemm/${pkgname}.git#tag=v${pkgver}"
+ "git+https://github.com/nullgemm/argoat.git"
+ "git+https://github.com/nullgemm/configator.git"
+ "git+https://github.com/nullgemm/ctypes.git"
+ "git+https://github.com/nullgemm/dragonfail.git"
+ "git+https://github.com/nullgemm/termbox_next.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ cp .github .gitmodules
+ git submodule init
+ for _i in argoat configator ctypes dragonfail termbox_next; do
+ git config submodule.sub/${_i}.url $srcdir/${_i}
+ done
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
package() {
- cd ly_0.5.0
- DESTDIR="$pkgdir" ./install.sh
- install -D -m644 license.md "${pkgdir}/usr/share/licenses/${pkgname}/WTFPL"
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 license.md "${pkgdir}/usr/share/licenses/${pkgname}/WTFPL"
}