summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWithTheBraid2022-07-14 07:36:31 +0200
committerWithTheBraid2022-07-14 07:36:31 +0200
commitc35a5c866df5194255da75b58edf480a2082f227 (patch)
tree6fca088cb0adfbf6663cf539c6131ca5604d3d56
parentf8bc43dc4cf2cbcf682bf6a82b92715b2ec37fb7 (diff)
downloadaur-c35a5c866df5194255da75b58edf480a2082f227.tar.gz
chore: bump version
- updates Flutter to 3.0.5 - adjusts post-install message to meet current state Signed-off-by: WithTheBraid <the-one@with-the-braid.cf>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--flutter.install4
3 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ac8206afce1..c86f5a22cb40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flutter
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
- pkgver = 3.0.4
+ pkgver = 3.0.5
pkgrel = 1
url = https://flutter.dev
install = flutter.install
@@ -25,10 +25,10 @@ pkgbase = flutter
options = !emptydirs
backup = opt/flutter/packages/flutter_test/pubspec.yaml
backup = opt/flutter/packages/flutter/pubspec.yaml
- source = flutter-3.0.4.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_3.0.4-stable.tar.xz
+ source = flutter-3.0.5.tar.xz::https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_3.0.5-stable.tar.xz
source = flutter.sh
source = flutter.csh
- sha256sums = f3806787f3afc379769024f4f9b20c243811881a72bc9c6e62bfc2fd50676c48
+ sha256sums = 691a125ce790faf8a34536b9bd298c31adbf2d2568fc9384e2d43a69c5c1d6cc
sha256sums = 1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a
sha256sums = 7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f
diff --git a/PKGBUILD b/PKGBUILD
index 0f61c38c2bd6..1a8300d3a38c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Philip Goto <philip.goto@gmail.com>, WithTheBraid <the-one@with-the-braid.cf>
pkgname=flutter
-pkgver=3.0.4
+pkgver=3.0.5
pkgrel=1
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64" "aarch64")
@@ -20,7 +20,7 @@ source=(
"${pkgname}.csh"
)
sha256sums=(
- "f3806787f3afc379769024f4f9b20c243811881a72bc9c6e62bfc2fd50676c48"
+ "691a125ce790faf8a34536b9bd298c31adbf2d2568fc9384e2d43a69c5c1d6cc"
"1dea1952d386c43948b9970382c2da5b65b7870684b8ad2ad89124e873aa485a"
"7ef10d753cfaac52d243549764a793f44f8284a1f4b11715ccd2fa915b026a6f"
)
@@ -37,7 +37,7 @@ package() {
"${pkgdir}/opt/${pkgname}/bin/flutter" precache
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod a+rx {} +
find "${pkgdir}/opt/${pkgname}" -type f -exec chmod a+r {} +
- # those files *must* be read-write for end-users
- chmod a+rw "${pkgdir}/opt/${pkgname}/version" "${pkgdir}/opt/${pkgname}/bin/cache/lockfile" "${pkgdir}/opt/${pkgname}/bin/cache/usbmuxd.stamp" "${pkgdir}/opt/${pkgname}/bin/cache/libmobiledevice.stamp"
+ # those files *must* be read-write for end-users; not my fault *grumble*
+ chmod a+rw "${pkgdir}/opt/${pkgname}/version" "${pkgdir}/opt/${pkgname}/bin/cache/lockfile" "${pkgdir}/opt/${pkgname}/bin/cache/usbmuxd.stamp" "${pkgdir}/opt/${pkgname}/bin/cache/libimobiledevice.stamp"
ln -s "/opt/${pkgname}/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
diff --git a/flutter.install b/flutter.install
index 4c6df18c795e..656de0ea1969 100644
--- a/flutter.install
+++ b/flutter.install
@@ -4,11 +4,9 @@ post_install() {
chmod -R g+w /opt/flutter
printf "$(tput setaf 4)Flutter was installed on $(tput setaf 2)/opt/flutter$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)If you intend to use it as a regular user, add your user into the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 4)In case you encounter problems using Flutter as regular user, add your user into the group flutterusers:$(tput sgr0)\n"
printf "$(tput setaf 2)gpasswd -a \${USER} flutterusers$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)You need to source $(tput setaf 2)/etc/profile$(tput setaf 4) or relogin to add flutter to your path.$(tput sgr0)\n"
- printf "$(tput setaf 4)$(tput sgr0)\n"
printf "$(tput setaf 4)Re-login your terminal in to the group flutterusers:$(tput sgr0)\n"
printf "$(tput setaf 2)newgrp flutterusers$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"