summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:11:34 +0200
committerMaxime Gauduin2015-06-08 11:11:34 +0200
commitc35ba1152affe0c12cf86f742cf8c4d4e98d988b (patch)
tree2e6c14e42d1bb01ad4bb29f7dd80a322ec992caf
downloadaur-c35ba1152affe0c12cf86f742cf8c4d4e98d988b.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD48
-rw-r--r--vapoursynth-editor.install14
-rw-r--r--vsedit.desktop11
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfba358650a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vapoursynth-editor
+ pkgdesc = VapourSynth script editor
+ pkgver = R4
+ pkgrel = 1
+ url = https://bitbucket.org/mystery_keeper/vapoursynth-editor
+ install = vapoursynth-editor.install
+ arch = i686
+ arch = x86_64
+ license = CCPL
+ license = MIT
+ makedepends = git
+ depends = desktop-file-utils
+ depends = qt5-base
+ depends = vapoursynth
+ source = git+https://bitbucket.org/mystery_keeper/vapoursynth-editor.git#tag=r4
+ source = vsedit.desktop
+ sha256sums = SKIP
+ sha256sums = b6d24441cf5746ea4dc08ecf379c67695bac663deb394db4334ba6aba9474c0f
+
+pkgname = vapoursynth-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08cfcf73af98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=vapoursynth-editor
+pkgver=R4
+pkgrel=1
+pkgdesc='VapourSynth script editor'
+arch=('i686' 'x86_64')
+url='https://bitbucket.org/mystery_keeper/vapoursynth-editor'
+license=('CCPL' 'MIT')
+depends=('desktop-file-utils' 'qt5-base' 'vapoursynth')
+makedepends=('git')
+install='vapoursynth-editor.install'
+source=("git+https://bitbucket.org/mystery_keeper/vapoursynth-editor.git#tag=${pkgver,}"
+ 'vsedit.desktop')
+sha256sums=('SKIP'
+ 'b6d24441cf5746ea4dc08ecf379c67695bac663deb394db4334ba6aba9474c0f')
+
+prepare() {
+ cd vapoursynth-editor
+
+ sed 's|QCoreApplication::applicationDirPath() + "/fonts"|"/usr/share/vsedit"|g' -i src/mainwindow.cpp
+}
+
+build() {
+ cd vapoursynth-editor/pro
+
+ qmake-qt5
+ make
+}
+
+package() {
+ if [[ $CARCH == i686 ]]; then
+ cd vapoursynth-editor/build/release-32bit-gcc
+ elif [[ $CARCH == x86_64 ]]; then
+ cd vapoursynth-editor/build/release-64bit-gcc
+ fi
+
+ install -dm 755 "${pkgdir}"/usr/{bin,share/{applications,pixmaps}}
+ install -m 755 vsedit "${pkgdir}"/usr/bin/
+ install -m 644 vsedit.svg "${pkgdir}"/usr/share/pixmaps/
+ install -m 644 ../../../vsedit.desktop "${pkgdir}"/usr/share/applications/
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses/vapoursynth-editor
+ install -m 644 LICENSE "${pkgdir}"/usr/share/licenses/vapoursynth-editor/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/vapoursynth-editor.install b/vapoursynth-editor.install
new file mode 100644
index 000000000000..e2c914b60db5
--- /dev/null
+++ b/vapoursynth-editor.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/vsedit.desktop b/vsedit.desktop
new file mode 100644
index 000000000000..a826d141e896
--- /dev/null
+++ b/vsedit.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=VapourSynth Editor
+Comment=VapourSynth script editor
+Exec=vsedit
+MimeType=text/x-vpy
+Icon=vsedit
+Terminal=false
+StartupNotify=false
+Categories=Utility;