summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-11-17 23:09:01 -0500
committerCarlos Aznarán2023-11-17 23:09:01 -0500
commitc3911312b6446de0480ab9098d49ca93e938b9f2 (patch)
treef990c1578d716ea719562f5dcde9daa86e2ad981
parentde55dd647a97510b591a9acdce1a8b83e96a719c (diff)
downloadaur-c3911312b6446de0480ab9098d49ca93e938b9f2.tar.gz
Skip some tests
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbf1a6a9aa3b..ad929ab2c48a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,9 +30,9 @@ check() {
python -m venv --system-site-packages test-env
test-env/bin/python -m installer ${_base}-${pkgver}/python/dist/*.whl
- test-env/bin/python -m pytest ${_base}-${pkgver}/python/test/unit \
+ MPLBACKEND=Agg test-env/bin/python -m pytest ${_base}-${pkgver}/python/test/unit \
-k 'not context_manager_anonymous and not nonmatching_mesh_interpolation and not nonmatching_mesh_single_cell_overlap_interpolation'
- test-env/bin/python -m pytest ${_base}-${pkgver}/python/demo/test.py
+ MPLBACKEND=Agg test-env/bin/python -m pytest ${_base}-${pkgver}/python/demo/test.py
}
package() {