summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-08-06 21:44:26 -0400
committerGuillaume Horel2020-08-06 21:44:26 -0400
commitc3af951b0ad35c61cbc49802ce8ccab277e7b4f9 (patch)
tree5da3bf25f6fffc695d25ff680e18f78f5f73792e
parentc06c1a8d541d3e6fabc0627eeac75e3899dd7e6e (diff)
downloadaur-c3af951b0ad35c61cbc49802ce8ccab277e7b4f9.tar.gz
add missing depend
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8c22228c39d..d8a15e8194c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,6 +18,7 @@ pkgbase = arrow
depends = gflags
depends = grpc>=1.27.0
depends = google-glog
+ depends = libutf8proc
depends = lz4
depends = protobuf
depends = rapidjson
diff --git a/PKGBUILD b/PKGBUILD
index 1bb5e0afca56..fad84bde80e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="A columnar in-memory analytics layer for big data."
arch=('x86_64')
url="https://arrow.apache.org"
license=('Apache')
-depends=('boost-libs' 'brotli' 'double-conversion' 'c-ares-cmake' 'gflags' 'grpc>=1.27.0' 'google-glog' 'lz4' 'protobuf' 'rapidjson' 'snappy' 'thrift' 'uriparser' 'zstd')
+depends=('boost-libs' 'brotli' 'double-conversion' 'c-ares-cmake' 'gflags' 'grpc>=1.27.0' 'google-glog' 'libutf8proc' 'lz4' 'protobuf' 'rapidjson' 'snappy' 'thrift' 'uriparser' 'zstd')
checkdepends=('git')
optdepends=()
provides=('parquet-cpp')
@@ -51,8 +51,7 @@ build(){
-DARROW_USE_GLOG=ON \
-DARROW_WITH_ZSTD=ON \
-DARROW_WITH_BROTLI=ON \
- -DGTest_SOURCE=BUNDLED \
- -DgRPC_ROOT="/usr"
+ -DGTest_SOURCE=BUNDLED
make
}
@@ -65,9 +64,9 @@ package(){
check(){
cd "$srcdir"
rm -rf parquet-testing
- git clone https://github.com/apache/parquet-testing.git
+ git clone --depth 1 https://github.com/apache/parquet-testing.git
rm -rf arrow-testing
- git clone https://github.com/apache/arrow-testing.git
+ git clone --depth 1 https://github.com/apache/arrow-testing.git
cd build
PARQUET_TEST_DATA="$srcdir/parquet-testing/data" ARROW_TEST_DATA="$srcdir/arrow-testing/data" make test
}