summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:11:30 -0700
committerAaron DeVore2015-07-08 11:11:30 -0700
commitc3bae80c31d49aec8dda166befc538efb8035a05 (patch)
treeb15c68374ff440daaa4db4c3b025f6ff9d5e80b1
downloadaur-c3bae80c31d49aec8dda166befc538efb8035a05.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD32
-rw-r--r--downpour.cfg15
-rw-r--r--downpour.install26
-rw-r--r--downpour.service11
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4bf52eb31ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = downpour
+ pkgdesc = Web-based BitTorrent client supporting auto-downloading from RSS and importing and renaming into a media library.
+ pkgver = 0.2
+ pkgrel = 3
+ url = http://jongsma.org/software/downpour/
+ install = downpour.install
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = python2
+ depends = twisted
+ depends = sqlite3
+ depends = python2-storm
+ depends = python2-jinja
+ depends = libtorrent
+ depends = python2-feedparser
+ depends = python2-dateutil
+ options = !emptydirs
+ source = http://jongsma.org/software/downpour/releases/Downpour-0.2.tar.gz
+ source = downpour.cfg
+ source = downpour.service
+ sha256sums = 1ce1e65932eb378a1624001f3cc7f9ac5096c5e9581e9e4a894a1e9c36c04103
+ sha256sums = 92c38a126edd17c25d1da060af5e704d81aa9acbef756a6255f9568a0f89524b
+ sha256sums = 76714f17aa69805bd7ba3c0390c811c054c3ead6fe12bd6d7b948c45319d5734
+
+pkgname = downpour
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ed2021ca0d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: graysky <graysky AT archlinux DOT org>
+pkgname=downpour
+pkgver=0.2
+pkgrel=3
+pkgdesc="Web-based BitTorrent client supporting auto-downloading from RSS and importing and renaming into a media library."
+arch=(any)
+url="http://jongsma.org/software/downpour/"
+license=('GPL')
+makedepends=('python2-distribute')
+depends=('python2' 'twisted' 'sqlite3' 'python2-storm' 'python2-jinja' 'libtorrent' 'python2-feedparser' 'python2-dateutil')
+options=(!emptydirs)
+install=downpour.install
+source=(http://jongsma.org/software/downpour/releases/Downpour-$pkgver.tar.gz
+ downpour.cfg downpour.service)
+sha256sums=('1ce1e65932eb378a1624001f3cc7f9ac5096c5e9581e9e4a894a1e9c36c04103'
+ '92c38a126edd17c25d1da060af5e704d81aa9acbef756a6255f9568a0f89524b'
+ '76714f17aa69805bd7ba3c0390c811c054c3ead6fe12bd6d7b948c45319d5734')
+
+build() {
+ cd "$srcdir/Downpour-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/Downpour-$pkgver"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 cfg/downpour.cfg "${pkgdir}/etc/downpour.cfg"
+ install -m755 -d "${pkgdir}/var/lib/downpour/downloads"
+ install -m755 -d "${pkgdir}/var/lib/downpour/tmp"
+ install -Dm644 "${srcdir}"/downpour.service "${pkgdir}/usr/lib/systemd/system/downpour.service"
+}
diff --git a/downpour.cfg b/downpour.cfg
new file mode 100644
index 000000000000..31beafb3242a
--- /dev/null
+++ b/downpour.cfg
@@ -0,0 +1,15 @@
+[downpour]
+user=downpour
+group=downpour
+state=/var/lib/downpour/downpour.db
+work_directory=/var/lib/downpour/tmp
+user_directory=/var/lib/downpour/downloads
+plugins=downpour.remote.RemotePlugin,downpour.web.WebInterfacePlugin
+
+[downpour.remote.RemotePlugin]
+interface=localhost
+port=6226
+
+[downpour.web.WebInterfacePlugin]
+interface=localhost
+port=6280
diff --git a/downpour.install b/downpour.install
new file mode 100644
index 000000000000..b2c9c306e28c
--- /dev/null
+++ b/downpour.install
@@ -0,0 +1,26 @@
+_add_user() {
+ useradd -c "downpour torrent" -d '/' -s /bin/false downpour
+ passwd -l downpour
+}
+
+post_install(){
+ _add_user
+ echo "
+>>> Start webinterface : localhost:6280
+>>> Log in Username : admin
+>>> Password : password
+"
+}
+
+post_upgrade(){
+ getent passwd downpour >/dev/null 2>&1 || _add_user
+}
+
+post_remove(){
+ if getent passwd downpour >/dev/null 2>&1; then
+ userdel downpour
+ fi
+ if getent group downpour >/dev/null 2>&1; then
+ groupdel downpour
+ fi
+}
diff --git a/downpour.service b/downpour.service
new file mode 100644
index 000000000000..5b9e025553a9
--- /dev/null
+++ b/downpour.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Web-based BitTorrent Client
+
+[Service]
+ExecStart=/usr/bin/downpourd -u downpour -g downpour start
+ExecStop=/usr/bin/downpourd stop
+Type=forking
+PIDFile=/var/run/downpour.pid
+
+[Install]
+WantedBy=multi-user.target