summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2024-04-29 11:39:40 +0200
committerMichal Wojdyla2024-04-29 11:39:40 +0200
commitc3bce8678acad184efda1b2a69516d64aaf2783b (patch)
tree31397536dc9cbe045a93e88e91bbf6a69a3146a1
parent272b9bcb0f55744b9ce56556249d2bdfaadbf4d6 (diff)
downloadaur-c3bce8678acad184efda1b2a69516d64aaf2783b.tar.gz
build with python311
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e01a6a2c0ce..bcf4f65c813e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = 0ad-git
pkgdesc = Cross-platform, 3D and historically-based real-time strategy game - built from git development version.
- pkgver = A26.r1310.g899a956de4
+ pkgver = A26.r1323.g7998bc697f
pkgrel = 1
epoch = 1
url = http://play0ad.com/
@@ -14,7 +14,7 @@ pkgbase = 0ad-git
makedepends = zip
makedepends = libsm
makedepends = rust
- makedepends = python
+ makedepends = python311
makedepends = git
makedepends = enet
makedepends = fmt
@@ -31,6 +31,7 @@ pkgbase = 0ad-git
makedepends = openal
makedepends = sdl2
makedepends = wxwidgets-gtk3
+ makedepends = which
options = !lto
options = !debug
source = git+https://github.com/0ad/0ad.git
diff --git a/PKGBUILD b/PKGBUILD
index 7136455b3561..dccbd7d92ceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@
pkgname=('0ad-git' '0ad-data-git')
_pkgname=0ad
epoch=1
-pkgver=A26.r1310.g899a956de4
+pkgver=A26.r1323.g7998bc697f
pkgrel=1
pkgdesc="Cross-platform, 3D and historically-based real-time strategy game - built from git development version."
arch=('i686' 'x86_64')
url="http://play0ad.com/"
license=('GPL-2.0-or-later' 'CCPL')
-makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python' 'git'
+makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python311' 'git'
'enet' 'fmt' 'gloox' 'glu' 'libgl' 'libminiupnpc.so' 'libogg'
'libpng' 'libsodium' 'libvorbis' 'miniupnpc' 'nspr' 'openal'
- 'sdl2' 'wxwidgets-gtk3')
+ 'sdl2' 'wxwidgets-gtk3' 'which')
options=('!lto' '!debug') # lto breaks spidermonkey linking (https://bugs.gentoo.org/746947)
source=("git+https://github.com/0ad/0ad.git" "patch.patch")
md5sums=('SKIP' 'dcbd62e1fb4669c24318c8fe66143c4f')
@@ -40,6 +40,8 @@ build() {
# this uses malloc_usable_size, which is incompatible with fortification level 3
export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
export CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+ # remove once this is fixed https://trac.wildfiregames.com/ticket/6895
+ export PYTHON3=python3.11
./update-workspaces.sh \
--without-pch \