summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang-Huang Bao2021-06-28 15:53:40 +0800
committerHuang-Huang Bao2021-06-28 15:53:40 +0800
commitc3beb0a6507c7a30213ad2ef8d3eba29cd17ade2 (patch)
treec6f3cf3611147f31d075676f67205d43e03e11e5
parentc4d0794cbc8d7bd4a63f6867646da24e04e9be30 (diff)
downloadaur-c3beb0a6507c7a30213ad2ef8d3eba29cd17ade2.tar.gz
extend arch list
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD7
3 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cb383548ba9..654796d823bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,12 @@ pkgbase = autofs-no-locking
pkgver = 5.1.7
pkgrel = 1
url = https://www.kernel.org/pub/linux/daemons/autofs/
+ arch = i686
arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL2
makedepends = libldap
makedepends = krb5
@@ -31,4 +36,3 @@ pkgbase = autofs-no-locking
sha256sums = SKIP
pkgname = autofs-no-locking
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bf6f72229a47
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+*
+!.gitignore
+
+!PKGBUILD
+!.SRCINFO
+!*.install
+
+!*.diff
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index ab804c986651..dd205c2c4229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,12 @@ pkgname=${_pkgbase}-no-locking
pkgver=5.1.7
pkgrel=1
pkgdesc='A kernel-based automounter for Linux (disable mount locking, allows recursive auto-mounting)'
-arch=('x86_64')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='https://www.kernel.org/pub/linux/daemons/autofs/'
license=('GPL2')
depends=('libxml2')
-provides=("autofs")
-conflicts=("autofs")
+provides=('autofs')
+conflicts=('autofs')
makedepends=('libldap' 'krb5' 'kmod' 'sssd' 'libnsl' 'rpcsvc-proto' 'systemd')
optdepends=('krb5: for LDAP support'
'sssd: for SSSD integration')
@@ -61,4 +61,3 @@ package() {
install -dm755 "$pkgdir/etc/autofs/auto.master.d"
}
-