summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhajosattila2022-12-15 14:54:17 +0100
committerhajosattila2022-12-15 14:54:17 +0100
commitc3beb48d31a5600e1df22da7d1f2c5424caa9fa1 (patch)
tree8c22239671a58294ca8d19581dfa6fc4e512b4fd
parent659e5b29e77b31f65d13e227c769e332081bcf81 (diff)
downloadaur-c3beb48d31a5600e1df22da7d1f2c5424caa9fa1.tar.gz
fixed PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5082999a273c..f13e7d992524 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = moc-unstable
arch = x86_64
license = GPL
makedepends = speex
- makedepends = ffmpeg
+ makedepends = ffmpeg4.4
makedepends = taglib
makedepends = libmpcdec
makedepends = wavpack
@@ -20,7 +20,7 @@ pkgbase = moc-unstable
depends = libltdl
depends = file
optdepends = speex: for using the speex plugin
- optdepends = ffmpeg: for using the ffmpeg plugin
+ optdepends = ffmpeg4.4: for using the ffmpeg plugin
optdepends = taglib: for using the musepack plugin
optdepends = libmpcdec: for using the musepack plugin
optdepends = wavpack: for using the wavpack plugin
@@ -34,9 +34,8 @@ pkgbase = moc-unstable
source = moc-https.patch
validpgpkeys = 59359B80406D9E73E80599BEF3121E4F2885A7AA
sha1sums = 01400a96b6e40346c15ad02c38d494e10721fd63
- sha1sums = SKIP
sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
+ sha1sums = SKIP
sha1sums = e3362ddd41126e2be874cd372a053fdaccf0f616
pkgname = moc-unstable
-
diff --git a/PKGBUILD b/PKGBUILD
index c97b2b57db71..42ce70687c68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Eric Bélanger <eric@archlinux.org>
+# Maintainer: Hajós Attila <linux.alucard@gmail.com>
+# Contributor: Eric Bélanger <eric@archlinux.org>
pkgname=moc-unstable
_pkgname=moc
@@ -11,13 +12,13 @@ arch=('x86_64')
url="https://moc.daper.net/"
license=('GPL')
depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
-makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
+makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
optdepends=('speex: for using the speex plugin'
- 'ffmpeg: for using the ffmpeg plugin'
+ 'ffmpeg4.4: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
'libmpcdec: for using the musepack plugin'
- 'wavpack: for using the wavpack plugin'
- 'faad2: for using the aac plugin'
+ 'wavpack: for using the wavpack plugin'
+ 'faad2: for using the aac plugin'
'libmodplug: for using the modplug plugin')
source=(http://ftp.daper.net/pub/soft/moc/unstable/${_pkgname}-${_pkgver}.tar.{xz,asc}
moc-ffmpeg4.patch
@@ -25,8 +26,8 @@ source=(http://ftp.daper.net/pub/soft/moc/unstable/${_pkgname}-${_pkgver}.tar.{x
conflicts=(moc)
provides=(moc)
sha1sums=('01400a96b6e40346c15ad02c38d494e10721fd63'
- 'SKIP'
'007a0580ac754e1c318a0d0b6f0d403883797eaf'
+ 'SKIP'
'e3362ddd41126e2be874cd372a053fdaccf0f616')
validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
@@ -38,6 +39,7 @@ prepare() {
build() {
cd ${_pkgname}-${_pkgver}
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
./configure --prefix=/usr --without-rcc \
--with-oss --with-alsa --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \