summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 21:19:51 +0100
committerBartłomiej Piotrowski2018-01-05 21:19:51 +0100
commitc3c79a5450744c877c472960be4bed2b2fca7c91 (patch)
tree24974d2087b1486313886a9f24b49c9be21492e4
downloadaur-c3c79a5450744c877c472960be4bed2b2fca7c91.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
-rw-r--r--license.txt29
-rw-r--r--trac.install11
-rw-r--r--tracd.service11
5 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fa1f0571f26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = trac
+ pkgdesc = Trac Integrated SCM & Project Management using Apache & Subversion.
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://trac.edgewall.org/
+ install = trac.install
+ arch = any
+ license = BSD
+ makedepends = clearsilver
+ depends = python2
+ depends = python2-genshi
+ depends = python2-babel
+ depends = python2-setuptools
+ source = http://ftp.edgewall.com/pub/trac/Trac-1.2.2.tar.gz
+ source = license.txt
+ source = tracd.service
+ sha256sums = 5ddeca9d2d47093f5791ef7e38ec9aff9c911258b8ba94c85a32ccd9274fc3b6
+ sha256sums = a0936aa2fab3714eb6a3e8ff64b730576d8a5f81340a0601f006c847761607c4
+ sha256sums = 3f050f1c9367b1b28e18a6ff0088f991676a9fbba3f5177859ce4db64f95ca42
+
+pkgname = trac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98290ea10a8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 239226 2017-06-21 09:53:44Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Rubin Simons <rubin@xs4all.nl>
+
+pkgname=trac
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Trac Integrated SCM & Project Management using Apache & Subversion."
+arch=('any')
+url="http://trac.edgewall.org/"
+license=('BSD')
+depends=(python2 python2-genshi python2-babel python2-setuptools)
+makedepends=(clearsilver)
+install=trac.install
+source=(http://ftp.edgewall.com/pub/trac/Trac-$pkgver.tar.gz
+ license.txt
+ tracd.service)
+sha256sums=('5ddeca9d2d47093f5791ef7e38ec9aff9c911258b8ba94c85a32ccd9274fc3b6'
+ 'a0936aa2fab3714eb6a3e8ff64b730576d8a5f81340a0601f006c847761607c4'
+ '3f050f1c9367b1b28e18a6ff0088f991676a9fbba3f5177859ce4db64f95ca42')
+
+package() {
+ cd "$srcdir"/Trac-$pkgver
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ install -D -m644 "$srcdir"/license.txt "$pkgdir"/usr/share/licenses/trac/license.txt
+ install -Dm0644 "$srcdir"/tracd.service "$pkgdir"/usr/lib/systemd/system/tracd.service
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..22b213f2f9f4
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,29 @@
+Copyright (C) 2003-2005 Edgewall Software
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+3. The name of the author may not be used to endorse or promote
+ products derived from this software without specific prior
+ written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR `AS IS'' AND ANY EXPRESS
+OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
+GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/trac.install b/trac.install
new file mode 100644
index 000000000000..b0ae2b13067e
--- /dev/null
+++ b/trac.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "-- tracd.service is an example. Copy it into /etc/systemd/... and edit"
+ echo "-- Please read http://trac.edgewall.org/wiki/TracInstall to install"
+ echo "-- additional requirements"
+ echo "--"
+ echo "-- DB engines are mandatory!!!"
+}
+
+post_upgrade() {
+ echo "-- tracd.service is an example. Copy it into /etc/systemd/... and edit"
+}
diff --git a/tracd.service b/tracd.service
new file mode 100644
index 000000000000..7d586b2268f5
--- /dev/null
+++ b/tracd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Trac service
+After=network.target remote-fs.target nss-lookup.target
+
+[Service]
+Type=simple
+# Example: copy it into /etc/systemd/ and edit.
+ExecStart=/usr/bin/tracd -b localhost -p 8080 --auth /tmp,/tmp/passwd,realm /tmp
+
+[Install]
+WantedBy=multi-user.target