summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Zhang2019-04-28 10:51:39 +0800
committerBruce Zhang2019-04-28 10:51:39 +0800
commitc3d2297eca262a2f6354182ce5d22ea37f7061b6 (patch)
tree8d8ed5792d05d6b4534457921c5a065ae0d44c35
downloadaur-c3d2297eca262a2f6354182ce5d22ea37f7061b6.tar.gz
ykdl: 1.6.3
Signed-off-by: Bruce Zhang <zttt183525594@gmail.com>
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1de5cacd7c36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ykdl
+ pkgdesc = a video downloader focus on China mainland video sites.
+ pkgver = 1.6.3
+ pkgrel = 1
+ url = https://github.com/zhangn1985/ykdl
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-m3u8
+ depends = python-pycryptodome
+ depends = python-urllib3
+ source = ykdl-1.6.3.src.tar.gz::https://github.com/zhangn1985/ykdl/archive/v1.6.3.tar.gz
+ sha256sums = 9fea4248d00bb706dd6cd1371b4b51b27c789fe4daf52008df83f26fc0d304bf
+
+pkgname = ykdl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..be2b8dad0ced
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.pkg.tar.xz
+*.src.tar.gz
+*.part
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83fb54f41824
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Bruce Zhang
+pkgname=ykdl
+pkgver=1.6.3
+pkgrel=1
+pkgdesc="a video downloader focus on China mainland video sites."
+arch=('any')
+url="https://github.com/zhangn1985/ykdl"
+license=('MIT')
+depends=('python' 'python-m3u8' 'python-pycryptodome' 'python-urllib3')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.src.tar.gz::https://github.com/zhangn1985/ykdl/archive/v1.6.3.tar.gz")
+sha256sums=('9fea4248d00bb706dd6cd1371b4b51b27c789fe4daf52008df83f26fc0d304bf')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/ykdl/LICENSE.txt"
+}