summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlaf Leidinger2017-01-26 10:03:18 +0100
committerOlaf Leidinger2017-01-26 10:03:18 +0100
commitc3dade4cc7510b89144c5c8813ef86e44197c47c (patch)
tree5934d1ac5ef3f2185403303e4615e184b2fecea7
parentffc24fb00b2b69f04b43afc6115022e555f1552e (diff)
downloadaur-c3dade4cc7510b89144c5c8813ef86e44197c47c.tar.gz
First version, based on linux-git
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
-rw-r--r--linux-git.preset14
-rw-r--r--linux-surface-pro-4-git.preset14
4 files changed, 48 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 324cf76fc39f..2fd5955ba10a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,5 @@
-# Generated by mksrcinfo v8
-# Sun Jan 22 22:39:17 UTC 2017
-pkgbase = linux-git
- pkgver = 4.10rc5.r0.g7a308bb3016f
+pkgbase = linux-surface-pro-4-git
+ pkgver = 4.9.r7.g8181ead45d71
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -15,17 +13,17 @@ pkgbase = linux-git
makedepends = git
makedepends = libelf
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
+ source = git+https://gitlab.com/jimdigriz/linux.git#branch=mssp4
source = config
source = config.x86_64
- source = linux-git.preset
+ source = linux-surface-pro-4-git.preset
sha256sums = SKIP
sha256sums = becc0c98cff692dee9500f19d38882636caf4c58d5086c7725690a245532f5dc
sha256sums = 356322a3fbb8c53d9d7002397537aa9614577ded430f27b6bc35793ba2e186f4
- sha256sums = 95fcfdfcb9d540d1a1428ce61e493ddf2c2a8ec96c8573deeadbb4ee407508c7
+ sha256sums = 6292681bf7aeead87d257f2fd95df1a2149effd5d5807aea40f0b1953e345efd
-pkgname = linux-git
- pkgdesc = The Linux kernel and modules (git version)
+pkgname = linux-surface-pro-4-git
+ pkgdesc = The Linux kernel and modules for MS Surface Pro 4 (git version)
install = linux.install
depends = coreutils
depends = linux-firmware
@@ -33,13 +31,13 @@ pkgname = linux-git
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
provides = linux
- backup = etc/mkinitcpio.d/linux-git.preset
+ backup = etc/mkinitcpio.d/linux-surface-pro-4-git.preset
-pkgname = linux-git-headers
- pkgdesc = Header files and scripts for building modules for Linux kernel (git version)
+pkgname = linux-surface-pro-4-git-headers
+ pkgdesc = Header files and scripts for building modules for Linux kernel (Surface Pro 4 git version)
provides = linux-headers
-pkgname = linux-git-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux kernel (git version)
+pkgname = linux-surface-pro-4-git-docs
+ pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux kernel (Surface Pro 4 git version)
provides = linux-docs
diff --git a/PKGBUILD b/PKGBUILD
index 670d266b9341..aed8a82b5b4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Boohbah <boohbah at gmail.com>
+# Maintainer: Olaf Leidinger <oleid@mescharet.de>
+# Contributor: Boohbah <boohbah at gmail.com>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Contributor: Jonathan Chan <jyc@fastmail.fm>
# Contributor: misc <tastky@gmail.com>
# Contributor: NextHendrix <cjones12 at sheffield.ac.uk>
-pkgbase=linux-git
+pkgbase=linux-surface-pro-4-git
_srcname=linux
-pkgver=4.10rc5.r0.g7a308bb3016f
+pkgver=4.9.r7.g8181ead45d71
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'libelf')
options=('!strip')
-source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git'
+source=('git+https://gitlab.com/jimdigriz/linux.git#branch=mssp4'
# the main kernel config files
'config' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -22,7 +23,7 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git'
sha256sums=('SKIP'
'becc0c98cff692dee9500f19d38882636caf4c58d5086c7725690a245532f5dc'
'356322a3fbb8c53d9d7002397537aa9614577ded430f27b6bc35793ba2e186f4'
- '95fcfdfcb9d540d1a1428ce61e493ddf2c2a8ec96c8573deeadbb4ee407508c7')
+ '6292681bf7aeead87d257f2fd95df1a2149effd5d5807aea40f0b1953e345efd')
_kernelname=${pkgbase#linux}
@@ -41,6 +42,12 @@ prepare() {
cat "${srcdir}/config" > ./.config
fi
+ # Inject config changes to Arch's default config
+ cat <<'EOF' >> .config
+CONFIG_INTEL_IPTS=m
+CONFIG_BLK_DEV_NVME=y
+EOF
+
# set localversion to git commit
sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"-${pkgver##*.}\"|g" ./.config
sed -i "s|CONFIG_LOCALVERSION_AUTO=.*|CONFIG_LOCALVERSION_AUTO=n|" ./.config
@@ -48,9 +55,6 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
- # get kernel version
- make prepare
-
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration
@@ -59,6 +63,9 @@ prepare() {
#make oldconfig # using old config from previous kernel version
make olddefconfig # old config from previous kernel, defaults for new options
# ... or manually edit .config
+
+ # get kernel version
+ make prepare
}
build() {
@@ -68,7 +75,7 @@ build() {
}
_package() {
- pkgdesc="The Linux kernel and modules (git version)"
+ pkgdesc="The Linux kernel and modules for MS Surface Pro 4 (git version)"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
provides=('linux')
@@ -107,8 +114,11 @@ _package() {
# remove build and source links
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
- # remove the firmware
+ # remove the firmware but the Intel touch screen firmware
+ mv "${pkgdir}/lib/firmware/intel/ipts" "${pkgdir}"
rm -rf "${pkgdir}/lib/firmware"
+ mkdir -p "${pkgdir}/lib/firmware/intel"
+ mv "${pkgdir}/ipts" "${pkgdir}/lib/firmware/intel"
# make room for external modules
ln -s "../extramodules-${_basekernel}${_kernelname:--ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
# add real version for building modules and running depmod from post_install/upgrade
@@ -130,7 +140,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for Linux kernel (git version)"
+ pkgdesc="Header files and scripts for building modules for Linux kernel (Surface Pro 4 git version)"
provides=('linux-headers')
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
@@ -255,7 +265,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel (git version)"
+ pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel (Surface Pro 4 git version)"
provides=('linux-docs')
cd "${_srcname}"
diff --git a/linux-git.preset b/linux-git.preset
deleted file mode 100644
index 899c8e2b2f41..000000000000
--- a/linux-git.preset
+++ /dev/null
@@ -1,14 +0,0 @@
-# mkinitcpio preset file for the 'linux-git' package
-
-ALL_config="/etc/mkinitcpio.conf"
-ALL_kver="/boot/vmlinuz-linux-git"
-
-PRESETS=('default' 'fallback')
-
-#default_config="/etc/mkinitcpio.conf"
-default_image="/boot/initramfs-linux-git.img"
-#default_options=""
-
-#fallback_config="/etc/mkinitcpio.conf"
-fallback_image="/boot/initramfs-linux-git-fallback.img"
-fallback_options="-S autodetect"
diff --git a/linux-surface-pro-4-git.preset b/linux-surface-pro-4-git.preset
new file mode 100644
index 000000000000..023328bf779e
--- /dev/null
+++ b/linux-surface-pro-4-git.preset
@@ -0,0 +1,14 @@
+# mkinitcpio preset file for the 'linux-surface-pro-4-git' package
+
+ALL_config="/etc/mkinitcpio.conf"
+ALL_kver="/boot/vmlinuz-linux-surface-pro-4-git"
+
+PRESETS=('default' 'fallback')
+
+#default_config="/etc/mkinitcpio.conf"
+default_image="/boot/initramfs-linux-surface-pro-4-git.img"
+#default_options=""
+
+#fallback_config="/etc/mkinitcpio.conf"
+fallback_image="/boot/initramfs-linux-surface-pro-4-git-fallback.img"
+fallback_options="-S autodetect"