summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2016-03-17 21:48:07 -0600
committerAinola2016-03-17 21:48:07 -0600
commitc3ed63d574cc438c14ced7dd10bbe62ae6e174b3 (patch)
tree84bf19e77ed28bb0a3ac2d91e79bb13befa7bf8e
downloadaur-c3ed63d574cc438c14ced7dd10bbe62ae6e174b3.tar.gz
migration from AUR3 and a few updates
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--creeper-world.desktop6
-rw-r--r--creeper-world.install12
-rwxr-xr-xcreeper-world.sh6
5 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20680a9eb067
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Mar 18 03:46:55 UTC 2016
+pkgbase = creeper-world
+ pkgdesc = Imagine an enemy that is everywhere and moves like a giant, organic mass across the map.
+ pkgver = 0632
+ pkgrel = 1
+ url = http://knucklecracker.com/creeperworld/cw.php
+ install = creeper-world.install
+ arch = any
+ license = custom
+ makedepends = unzip
+ depends = adobe-air-sdk
+ noextract = CreeperWorld-0632.exe
+ source = http://knucklecracker.com/creeperworld/dd_webb/CreeperWorld-0632.exe
+ source = creeper-world.desktop
+ source = creeper-world.sh
+ sha256sums = 6ddfcaa307e36d8761049177de1dbd6c95acc7536c4ff9b2412687e3367e6afc
+ sha256sums = ec5f8b5de88ad3ad1291c8cbea7d2e91e3d3daca0209fc4f5e8fd283fab0a74d
+ sha256sums = 809a86452f621dfcb73f1b3b6ef0c2b482315d6f822e14c20ffd720199fc495e
+
+pkgname = creeper-world
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4622d035362d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ainola
+# Contributor: Felix Berkenkamp
+
+pkgname=creeper-world
+pkgver=0632
+pkgrel=1
+pkgdesc="Imagine an enemy that is everywhere and moves like a giant, organic mass across the map."
+arch=('any')
+url="http://knucklecracker.com/creeperworld/cw.php"
+license=('custom')
+depends=('adobe-air-sdk')
+makedepends=('unzip')
+source=(http://knucklecracker.com/creeperworld/dd_webb/CreeperWorld-${pkgver}.exe
+ creeper-world.desktop
+ creeper-world.sh)
+noextract=(CreeperWorld-${pkgver}.exe)
+install="$pkgname".install
+sha256sums=('6ddfcaa307e36d8761049177de1dbd6c95acc7536c4ff9b2412687e3367e6afc'
+ 'ec5f8b5de88ad3ad1291c8cbea7d2e91e3d3daca0209fc4f5e8fd283fab0a74d'
+ '809a86452f621dfcb73f1b3b6ef0c2b482315d6f822e14c20ffd720199fc495e')
+
+package() {
+ cd "$srcdir"
+ unzip CreeperWorld-${pkgver}.exe
+ unzip CreeperWorld-${pkgver}.air
+
+ mkdir -p "$pkgdir"/usr/share/{"$pkgname",applications}
+ mkdir -p "$pkgdir"/usr/bin
+
+ cp -r icons Main.swf META-INF mimetype "$pkgdir/usr/share/$pkgname/"
+ for size in 16 32 48 64 128; do
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/"
+ ln -s "/usr/share/$pkgname/icons/cw$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/creeper-world.png"
+ done
+
+ install -Dm644 "$pkgname".desktop "${pkgdir}/usr/share/applications/"
+ install -Dm755 "$pkgname".sh "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/creeper-world.desktop b/creeper-world.desktop
new file mode 100644
index 000000000000..b84a1cbc2580
--- /dev/null
+++ b/creeper-world.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Exec=creeper-world
+Icon=creeper-world
+Type=Application
+Name=Creeper World
+Categories=Game;AudioVideo
diff --git a/creeper-world.install b/creeper-world.install
new file mode 100644
index 000000000000..a907e70974c7
--- /dev/null
+++ b/creeper-world.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/creeper-world.sh b/creeper-world.sh
new file mode 100755
index 000000000000..4bd7bb5774ae
--- /dev/null
+++ b/creeper-world.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+/opt/adobe-air-sdk/bin/adl \
+ -nodebug \
+ /usr/share/creeper-world/META-INF/AIR/application.xml \
+ /usr/share/creeper-world &