summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Arms2021-09-25 19:47:36 +1000
committerLuke Arms2021-09-25 19:47:36 +1000
commitc3ee87971ef66f0613af8119d585219558b3cbfc (patch)
tree8a371294dd876690bb0cf770782d1426213194c9
parentedcc81b6d26520da7c5d476dd633b6b626e5dcba (diff)
downloadaur-c3ee87971ef66f0613af8119d585219558b3cbfc.tar.gz
Increase size of emoji in skin tone pop-up window
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--fix-skin-tone-static-path.patch22
3 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a0673eda5d4..2d113b3450f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = emote
pkgdesc = Emoji Picker for Linux written in GTK3
pkgver = 3.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tom-james-watson/Emote
arch = any
license = GPL3
@@ -19,6 +19,6 @@ pkgbase = emote
source = fix-skin-tone-static-path.patch
sha512sums = SKIP
sha512sums = ef8caea8ad9e9bc0487dd8c816561027adda743c1e8e2779a64e7ae99fb227c820f31ef9c87fb910bae7a8ffc623e5e2e1a53a8c69ce0a35ad96557e97a5a949
- sha512sums = 332917b145cdfc2bc80fcac310cc21df1d0dcb1bec78b675930383295d074f80a176fec0d4c35ab7728a5bc948c05f53ce4037504e21f8f41708b5de2393edf1
+ sha512sums = 52d3dce0cecfe62ccc4469b4b35b27c8332d6dce2d1e2dd5603c85a3025fb4a415df303eaaace5579c4204923cbd8d86846deb1026a01f8b201452453c61746f
pkgname = emote
diff --git a/PKGBUILD b/PKGBUILD
index 39a84de69372..745b1eae043b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=emote
pkgver=3.0.3
_pkgref=ff40e3d66b251aaf2e91116ba177e59f087e1021
-pkgrel=2
+pkgrel=3
url="https://github.com/tom-james-watson/Emote"
pkgdesc="Emoji Picker for Linux written in GTK3"
arch=('any')
@@ -18,7 +18,7 @@ source=(
sha512sums=(
'SKIP'
'ef8caea8ad9e9bc0487dd8c816561027adda743c1e8e2779a64e7ae99fb227c820f31ef9c87fb910bae7a8ffc623e5e2e1a53a8c69ce0a35ad96557e97a5a949'
- '332917b145cdfc2bc80fcac310cc21df1d0dcb1bec78b675930383295d074f80a176fec0d4c35ab7728a5bc948c05f53ce4037504e21f8f41708b5de2393edf1'
+ '52d3dce0cecfe62ccc4469b4b35b27c8332d6dce2d1e2dd5603c85a3025fb4a415df303eaaace5579c4204923cbd8d86846deb1026a01f8b201452453c61746f'
)
build() {
diff --git a/fix-skin-tone-static-path.patch b/fix-skin-tone-static-path.patch
index 920c0f181b82..9ea52c25954e 100644
--- a/fix-skin-tone-static-path.patch
+++ b/fix-skin-tone-static-path.patch
@@ -614,10 +614,16 @@ index d63c27a..07093af 100644
emojis_by_category["recent"].append(emoji)
diff --git a/emote/picker.py b/emote/picker.py
-index 5e98c1c..be20315 100644
+index 5e98c1c..1add085 100644
--- a/emote/picker.py
+++ b/emote/picker.py
-@@ -130,14 +130,14 @@ class EmojiPicker(Gtk.Window):
+@@ -125,19 +125,19 @@ class EmojiPicker(Gtk.Window):
+ return menu_button
+
+ def init_skintone_button(self):
+- skintone_combo = Gtk.ComboBoxText()
++ skintone_combo = Gtk.ComboBoxText(name="skintone_combo")
+ skintone_combo.set_entry_text_column(0)
skintone_combo.connect("changed", self.on_skintone_combo_changed)
for skintone in user_data.SKINTONES:
@@ -2172,6 +2178,18 @@ index a26f7c1..9e6a4e7 100644
🏳️‍🌈,1F3F3-FE0F-200D-1F308,flags,flag,rainbow flag,"pride, rainbow",color,Romain Bazile,2019-09-11,,,,,4,4322
🏳️‍⚧️,1F3F3-FE0F-200D-26A7-FE0F,flags,flag,transgender flag,"flag, light blue, pink, transgender, white","LGBT, trans, queer, gender",Carlin MacKenzie,2020-01-09,,,,,13,4324
🏴‍☠️,1F3F4-200D-2620-FE0F,flags,flag,pirate flag,"jolly roger, pirate, plunder, treasure",,Aileen Gedrat,2018-11-16,,,,,11,4328
+diff --git a/static/style.css b/static/style.css
+index 7b36c1c..9ae2533 100644
+--- a/static/style.css
++++ b/static/style.css
+@@ -1,3 +1,7 @@
++#skintone_combo window {
++ font-size: 24px;
++}
++
+ #category_selector_button {
+ font-size: 20px;
+ padding-top: 5px;
diff --git a/update-emojis b/update-emojis
new file mode 100755
index 0000000..d9a33f0