summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2019-01-17 22:56:39 -0500
committeralgebro2019-01-17 22:56:39 -0500
commitc41ee6d907e8f1ece4f2d5fe2e7ef71714a1f5df (patch)
treeaf1d80d221d2ee9698dc86d115acb2d24647aa45
downloadaur-c41ee6d907e8f1ece4f2d5fe2e7ef71714a1f5df.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df4ad1a9c54e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyevmasm
+ pkgdesc = Assembler and disassembler library for the Ethereum Virtual Machine (EVM)
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/trailofbits/pyevmasm
+ arch = x86_64
+ license = Apache License 2.0
+ depends = python
+ depends = python-future
+ source = https://files.pythonhosted.org/packages/source/p/pyevmasm/pyevmasm-0.2.0.tar.gz
+ sha256sums = 777863b70d8595e2755e7743d448e2bddb9181ae295d33af55e99a36c0f3cc58
+
+pkgname = python-pyevmasm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea529f53928e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: algebro <algebro at tuta dot io>
+
+_pkgname=pyevmasm
+pkgname=python-$_pkgname
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Assembler and disassembler library for the Ethereum Virtual Machine (EVM)"
+arch=('x86_64')
+url="https://github.com/trailofbits/pyevmasm"
+license=('Apache License 2.0')
+depends=('python' 'python-future')
+source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('777863b70d8595e2755e7743d448e2bddb9181ae295d33af55e99a36c0f3cc58')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}