summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:22 +0200
committerMuflone2015-06-13 17:59:22 +0200
commitc436f72103f717ea81bbcdebff6814b02021ad93 (patch)
tree60a24e7e716d0d81e8a911829419a4a43c7c92e1
downloadaur-c436f72103f717ea81bbcdebff6814b02021ad93.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rw-r--r--membrane-soap.desktop9
-rw-r--r--membrane-soap.install11
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd8fcb5c04da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = membrane-soap
+ pkgdesc = Generic SOAP client with a dynamic form generator for SOAP requests.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://www.membrane-soa.org/soap-client/
+ install = membrane-soap.install
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = java-runtime
+ depends = desktop-file-utils
+ source = http://mirror.predic8.com/membrane/client/linux-x86/membrane-client-linux.gtk.x86-1.3.1.tar
+ source = membrane-soap.desktop
+ md5sums = 25a96915b83e3b6e7922c822a81abf0d
+ md5sums = fac69611ec1ae412cebac29545399c26
+
+pkgname = membrane-soap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51ea409cfcfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=membrane-soap
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Generic SOAP client with a dynamic form generator for SOAP requests."
+arch=('i686' 'x86_64')
+url="http://www.membrane-soa.org/soap-client/"
+license=('APACHE')
+depends=('java-runtime' 'desktop-file-utils')
+install="${pkgname}.install"
+source=("http://mirror.predic8.com/membrane/client/linux-x86/membrane-client-linux.gtk.x86-${pkgver}.tar"
+ "${pkgname}.desktop")
+md5sums=('25a96915b83e3b6e7922c822a81abf0d'
+ 'fac69611ec1ae412cebac29545399c26')
+if [ "$CARCH" = 'x86_64' ]; then
+ source[0]="http://mirror.predic8.com/membrane/client/linux-x64/membrane-client-linux.gtk.x86_64-${pkgver}.tar"
+ md5sums[0]='25a96915b83e3b6e7922c822a81abf0d'
+fi
+
+package() {
+ # Install the desktop file
+ install -m 755 -d "${pkgdir}/usr/share/applications"
+ install -m 755 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ # Copy all the required files
+ if [ "$CARCH" = 'x86_64' ]; then
+ cd "linux.gtk.x86_64"
+ else
+ cd "linux.gtk.x86"
+ fi
+ install -m 755 -d "${pkgdir}/usr/lib/${pkgname}"
+ cp -r configuration plugins membrane-client membrane-client.ini "${pkgdir}/usr/lib/${pkgname}"
+ # Create the symbolic link to the executable
+ install -m 755 -d "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/${pkgname}/membrane-client" "${pkgdir}/usr/bin/${pkgname}"
+ # Install the icon
+ unzip -q -o -j plugins/com.predic8.rcp.membrane_client_${pkgver}.jar "icons/logo32.png"
+ install -m 755 -d "${pkgdir}/usr/share/pixmaps"
+ install -m 644 "logo32.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
diff --git a/membrane-soap.desktop b/membrane-soap.desktop
new file mode 100644
index 000000000000..fb42deccf920
--- /dev/null
+++ b/membrane-soap.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Membrane SOAP client
+GenericName==Membrane SOAP client
+Exec=membrane-soap
+Terminal=false
+Type=Application
+Icon=membrane-soap.png
+Categories=Network;
+StartupWMClass=Membrane-SOAP-Client
diff --git a/membrane-soap.install b/membrane-soap.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/membrane-soap.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}