summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-08 23:44:05 -0600
committerBrian Bidulock2015-07-08 23:44:05 -0600
commitc4721f2705bb6adbaa0def2a9aff0cba24142ec4 (patch)
tree39628056c513d3467dc714e404bbf6b5ffce7b46
downloadaur-c4721f2705bb6adbaa0def2a9aff0cba24142ec4.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE26
-rw-r--r--PKGBUILD27
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9910207c7a43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fbautostart
+ pkgdesc = Lightweight XDG autostarter for Fluxbox
+ pkgver = 2.718281828
+ pkgrel = 1
+ url = https://launchpad.net/fbautostart
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = gcc-libs
+ source = https://launchpad.net/fbautostart/fbautostart/2.718281828/+download/fbautostart-2.718281828.tar.gz
+ source = LICENSE
+ md5sums = 06495f9b23b1c9b1bf35c2346cb48f63
+ md5sums = 3b20fd23a403ee99b09928d2c3b70e19
+
+pkgname = fbautostart
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1c53b3bb783b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,26 @@
+Copyright: 2010-2012, Paul Tagliamonte <paultag@ubuntu.com>
+License: BSD-3
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ .
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. Neither the name of the University nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..092e2a5a69d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Brian Bidulock <bidulock@openss7.org>
+pkgname=fbautostart
+pkgver=2.718281828
+pkgrel=1
+pkgdesc="Lightweight XDG autostarter for Fluxbox"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/fbautostart"
+depends=('gcc-libs')
+license=('BSD')
+source=("https://launchpad.net/$pkgname/$pkgname/$pkgver/+download/$pkgname-$pkgver.tar.gz" "LICENSE")
+md5sums=('06495f9b23b1c9b1bf35c2346cb48f63'
+ '3b20fd23a403ee99b09928d2c3b70e19')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ install -Dm644 $startdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: