summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreedts2017-03-04 14:15:45 +0100
committerreedts2017-03-04 14:15:45 +0100
commitc4761687254ae08b26abbf6f116285718dc0d857 (patch)
tree3a52f3d7e3b7fa4d31139b90662e23b216bb9ffe
downloadaur-c4761687254ae08b26abbf6f116285718dc0d857.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ef316d53016
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-nord-git
+ pkgdesc = A arctic, north-bluish clean and elegant Vim theme.
+ pkgver = r51.05d536f
+ pkgrel = 1
+ url = https://github.com/arcticicestudio/nord-vim
+ arch = any
+ groups = vim-plugins
+ license = Apache
+ makedepends = git
+ depends = vim
+ source = vim-nord-git::git+https://github.com/arcticicestudio/nord-vim.git
+ md5sums = SKIP
+
+pkgname = vim-nord-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e92936ef6d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: reedts <j.reedts at gmail dot com>
+pkgname=vim-nord-git
+pkgver=r51.05d536f
+pkgrel=1
+epoch=
+pkgdesc="A arctic, north-bluish clean and elegant Vim theme."
+arch=('any')
+url="https://github.com/arcticicestudio/nord-vim"
+license=('Apache')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+source=("$pkgname::git+https://github.com/arcticicestudio/nord-vim.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 colors/nord.vim $pkgdir/usr/share/vim/vimfiles/colors/nord.vim
+}
+