summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-12 13:36:45 +0300
committerCaleb Maclennan2020-02-12 13:36:45 +0300
commitc477ea7e7ce8bbcb318f881bfaf5459e786cb47f (patch)
treeeb87b5f64dc0dc7ceebda1bad3e6f0563dcdc2ed
parent1bef0a89e589ab7905b5012512265ec910ef6328 (diff)
downloadaur-c477ea7e7ce8bbcb318f881bfaf5459e786cb47f.tar.gz
Cleanup bash shell quoting using shellharden
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2dedaa5707fc..46a439df0e1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,12 @@ arch=('i686' 'x86_64')
url="https://keplerproject.github.io/$_rockname"
license=('MIT')
makedepends=('luarocks')
-source=("${_rockname}-${pkgver}.tar.gz::https://github.com/keplerproject/$_rockname/archive/v$pkgver.tar.gz")
+source=("$_rockname-$pkgver.tar.gz::https://github.com/keplerproject/$_rockname/archive/v$pkgver.tar.gz")
sha256sums=('b48eb004f0a74bc64aa1419d9999057b9595668c37abfa4a126de4083d89ef44')
_package_helper() {
cd "$_rockname-$pkgver"
- luarocks --lua-version=$1 --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-scm-$_rockrel.rockspec"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-scm-$_rockrel.rockspec"
find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
}