summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-06-08 12:17:52 +0200
committerJan Cholasta2020-06-08 12:17:52 +0200
commitc479a6029df2d5b9df2cc8ef80c72f16be5d6d32 (patch)
tree128ea881663c5170daaa18c11e9b77107e4bdc83
parent22f06efab8ede0ab9526b441b841894c4641ba57 (diff)
downloadaur-c479a6029df2d5b9df2cc8ef80c72f16be5d6d32.tar.gz
raze-git-0.6.0+485+g5330964a7-1
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-file-paths.patch68
-rw-r--r--PKGBUILD6
3 files changed, 40 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a742133719aa..b0156ba32f72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = raze-git
pkgdesc = Build engine port backed by GZDoom tech (git version)
- pkgver = 0.6.0+58+g2881cff75
+ pkgver = 0.6.0+485+g5330964a7
pkgrel = 1
url = https://github.com/coelckers/Raze
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = raze-git
depends = libvpx
depends = openal
depends = sdl2
- depends = zmusic
+ depends = zmusic>=1.1.1
optdepends = gxmessage: crash dialog (GNOME)
optdepends = kdialog: crash dialog (KDE)
optdepends = xorg-xmessage: crash dialog (other)
@@ -26,7 +26,7 @@ pkgbase = raze-git
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = 8d304c587ef9545da3c00e6314b8bc76f87f5650b97f95b4e1d994e08347334c
+ sha256sums = 363b00bbc3022f584b93aaef704a192a5aa1cce2e72f295b2bf89ecce87050fd
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze-git
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index d27ade9c332a..cc8b05379972 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,13 +1,13 @@
-From 125e3293d068aa641dd29d4b51f8c37b6f464884 Mon Sep 17 00:00:00 2001
+From a8beb39ac0babaa9516a9888b35d1bfe657c0747 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Thu, 6 Feb 2020 07:59:18 +0100
Subject: [PATCH] Fix file paths
---
- source/common/audio/music/i_soundfont.cpp | 4 +---
- source/core/gameconfigfile.cpp | 13 +------------
- source/core/gamecontrol.cpp | 2 +-
- source/platform/posix/sdl/i_main.cpp | 14 +-------------
+ source/common/audio/music/i_soundfont.cpp | 4 +---
+ source/common/platform/posix/sdl/i_main.cpp | 14 +-------------
+ source/core/gameconfigfile.cpp | 13 +------------
+ source/core/gamecontrol.cpp | 2 +-
4 files changed, 4 insertions(+), 29 deletions(-)
diff --git a/source/common/audio/music/i_soundfont.cpp b/source/common/audio/music/i_soundfont.cpp
@@ -25,8 +25,33 @@ index a8b4e9fdf..911b8e308 100644
};
#else
const char *paths[] = {
+diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
+index 7fc179a51..fb4ce733e 100644
+--- a/source/common/platform/posix/sdl/i_main.cpp
++++ b/source/common/platform/posix/sdl/i_main.cpp
+@@ -129,19 +129,7 @@ int main (int argc, char **argv)
+ Args = new FArgs(argc, argv);
+
+ // Should we even be doing anything with progdir on Unix systems?
+- char program[PATH_MAX];
+- if (realpath (argv[0], program) == NULL)
+- strcpy (program, argv[0]);
+- char *slash = strrchr (program, '/');
+- if (slash != NULL)
+- {
+- *(slash + 1) = '\0';
+- progdir = program;
+- }
+- else
+- {
+- progdir = "./";
+- }
++ progdir = "/usr/lib/raze/";
+
+ I_StartupJoysticks();
+
diff --git a/source/core/gameconfigfile.cpp b/source/core/gameconfigfile.cpp
-index dd4c0889e..ae7d282d4 100644
+index b532b2925..8ffd663b1 100644
--- a/source/core/gameconfigfile.cpp
+++ b/source/core/gameconfigfile.cpp
@@ -100,15 +100,10 @@ FGameConfigFile::FGameConfigFile ()
@@ -70,10 +95,10 @@ index dd4c0889e..ae7d282d4 100644
}
diff --git a/source/core/gamecontrol.cpp b/source/core/gamecontrol.cpp
-index d5650c85a..7f2ae609b 100644
+index 92b6c47ae..1d8bf338c 100644
--- a/source/core/gamecontrol.cpp
+++ b/source/core/gamecontrol.cpp
-@@ -639,7 +639,7 @@ int RunGame()
+@@ -749,7 +749,7 @@ int RunGame()
FString logfile = Args->TakeValue("+logfile");
// As long as this engine is still in prerelease mode let's always write a log file.
@@ -82,31 +107,6 @@ index d5650c85a..7f2ae609b 100644
if (logfile.IsNotEmpty())
{
-diff --git a/source/platform/posix/sdl/i_main.cpp b/source/platform/posix/sdl/i_main.cpp
-index e593963ac..314f757fa 100644
---- a/source/platform/posix/sdl/i_main.cpp
-+++ b/source/platform/posix/sdl/i_main.cpp
-@@ -124,19 +124,7 @@ int main (int argc, char **argv)
- Args = new FArgs(argc, argv);
-
- // Should we even be doing anything with progdir on Unix systems?
-- char program[PATH_MAX];
-- if (realpath (argv[0], program) == NULL)
-- strcpy (program, argv[0]);
-- char *slash = strrchr (program, '/');
-- if (slash != NULL)
-- {
-- *(slash + 1) = '\0';
-- progdir = program;
-- }
-- else
-- {
-- progdir = "./";
-- }
-+ progdir = "/usr/lib/raze/";
-
- I_StartupJoysticks();
-
--
-2.26.0
+2.27.0
diff --git a/PKGBUILD b/PKGBUILD
index 589c66fda9a7..56e4f12c71db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=raze-git
-pkgver=0.6.0+58+g2881cff75
+pkgver=0.6.0+485+g5330964a7
pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech (git version)'
arch=('x86_64')
@@ -14,7 +14,7 @@ depends=('gtk3'
'libvpx'
'openal'
'sdl2'
- 'zmusic')
+ 'zmusic>=1.1.1')
makedepends=('cmake'
'desktop-file-utils'
'git')
@@ -27,7 +27,7 @@ source=("Raze::git+https://github.com/coelckers/Raze"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- '8d304c587ef9545da3c00e6314b8bc76f87f5650b97f95b4e1d994e08347334c'
+ '363b00bbc3022f584b93aaef704a192a5aa1cce2e72f295b2bf89ecce87050fd'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
pkgver() {