summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2023-04-19 21:34:43 +0200
committerStephan Springer2023-04-19 21:34:43 +0200
commitc47d820aeb364246336bb34ceb7ca6219531fed0 (patch)
tree55f261c329557c809e4b2363c6b9793293bc27a8
parentbff351eeea8acaad8f0a72196e12d69a488e6637 (diff)
downloadaur-c47d820aeb364246336bb34ceb7ca6219531fed0.tar.gz
update to version 6.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71baae200f1c..3290a30fe256 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt6-base-headless
pkgdesc = A cross-platform application and UI framework - headless build, no QtGui or QtWidgets
- pkgver = 6.4.3
+ pkgver = 6.5.0
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -27,10 +27,10 @@ pkgbase = qt6-base-headless
optdepends = shared-mime-info: Freedesktop.org Shared MIME Info
provides = qt6-base
conflicts = qt6-base
- source = https://download.qt.io/official_releases/qt/6.4/6.4.3/submodules/qtbase-everywhere-src-6.4.3.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.5/6.5.0/submodules/qtbase-everywhere-src-6.5.0.tar.xz
source = qt6-base-cflags.patch
source = qt6-base-nostrip.patch
- sha256sums = 5087c9e5b0165e7bc3c1a4ab176b35d0cd8f52636aea903fa377bdba00891a60
+ sha256sums = fde1aa7b4fbe64ec1b4fc576a57f4688ad1453d2fab59cbadd948a10a6eaf5ef
sha256sums = 5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78
sha256sums = 4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094
diff --git a/PKGBUILD b/PKGBUILD
index f362879d9569..d1ed17b27e95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt6-base-headless
-_qtver=6.4.3
+_qtver=6.5.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(x86_64)
@@ -25,7 +25,7 @@ _pkgfn="qtbase-everywhere-src-$_qtver"
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
qt6-base-cflags.patch
qt6-base-nostrip.patch)
-sha256sums=('5087c9e5b0165e7bc3c1a4ab176b35d0cd8f52636aea903fa377bdba00891a60'
+sha256sums=('fde1aa7b4fbe64ec1b4fc576a57f4688ad1453d2fab59cbadd948a10a6eaf5ef'
'5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78'
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
@@ -47,9 +47,10 @@ build() {
-DINSTALL_INCLUDEDIR=include/qt6 \
-DINSTALL_MKSPECSDIR=lib/qt6/mkspecs \
-DINSTALL_EXAMPLESDIR=share/doc/qt6/examples \
- -DQT_FEATURE_journald=ON \
- -DQT_FEATURE_openssl_linked=ON \
- -DQT_FEATURE_system_sqlite=ON \
+ -DFEATURE_journald=ON \
+ -DFEATURE_openssl_linked=ON \
+ -DFEATURE_system_sqlite=ON \
+ -DFEATURE_no_direct_extern_access=ON \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DCMAKE_MESSAGE_LOG_LEVEL=STATUS \
\