summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-04-06 18:43:09 -0500
committerBao Trinh2023-04-06 18:43:09 -0500
commitc48d4e045f2128a14a6c6cfd42104de8b029e12d (patch)
treeb7e8abc9cb35eb2a610aa5be65a17f1e117772f6
parent63ecf6f91c1c7ed1f148061cfc3975d481e1281c (diff)
downloadaur-c48d4e045f2128a14a6c6cfd42104de8b029e12d.tar.gz
build from source
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e328814b3032..4fbe61e98cb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = qbittorrent-cli
pkgdesc = Command line interface for QBittorrent
pkgver = 1.7.23016.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fedarovich/qbittorrent-cli
+ arch = i686
arch = x86_64
arch = arm
arch = aarch64
license = MIT
+ makedepends = dotnet-sdk-6.0
depends = dotnet-runtime>=6.0
options = !strip
- source_x86_64 = https://github.com/fedarovich/qbittorrent-cli/releases/download/v1.7.23016.1/qbt-linux-x64-net6-1.7.23016.1.tar.gz
- sha256sums_x86_64 = 26a345a380657ea5be19e19c09e71571b4e11fd5c512e380f992b1665ec76637
- source_arm = https://github.com/fedarovich/qbittorrent-cli/releases/download/v1.7.23016.1/qbt-linux-arm-net6-1.7.23016.1.tar.gz
- sha256sums_arm = 245dd819a01825c3e063e534987e21a15325319c4c2ba663e1c8c0a8a9f09104
- source_aarch64 = https://github.com/fedarovich/qbittorrent-cli/releases/download/v1.7.23016.1/qbt-linux-arm64-net6-1.7.23016.1.tar.gz
- sha256sums_aarch64 = 5bd6284e8b91b39758e0c54a97b130f71a3882f1b57bd3987be38f62bd997b2c
+ source = qbittorrent-cli-1.7.23016.1.tar.gz::https://github.com/fedarovich/qbittorrent-cli/archive/refs/tags/v1.7.23016.1.tar.gz
+ sha256sums = ff5c53b50383c0eb478d485981556ed350645f8e8bf380630b1b0c7d3794cf32
pkgname = qbittorrent-cli
diff --git a/PKGBUILD b/PKGBUILD
index 346816b4c739..38d9f539d0c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,37 @@
pkgname=qbittorrent-cli
pkgver=1.7.23016.1
-pkgrel=1
+pkgrel=2
pkgdesc='Command line interface for QBittorrent '
-arch=('x86_64' 'arm' 'aarch64')
+arch=('i686' 'x86_64' 'arm' 'aarch64')
url="https://github.com/fedarovich/qbittorrent-cli"
license=('MIT')
depends=('dotnet-runtime>=6.0')
-source_x86_64=("https://github.com/fedarovich/qbittorrent-cli/releases/download/v${pkgver}/qbt-linux-x64-net6-${pkgver}.tar.gz")
-source_arm=("https://github.com/fedarovich/qbittorrent-cli/releases/download/v${pkgver}/qbt-linux-arm-net6-${pkgver}.tar.gz")
-source_aarch64=("https://github.com/fedarovich/qbittorrent-cli/releases/download/v${pkgver}/qbt-linux-arm64-net6-${pkgver}.tar.gz")
-sha256sums_x86_64=('26a345a380657ea5be19e19c09e71571b4e11fd5c512e380f992b1665ec76637')
-sha256sums_arm=('245dd819a01825c3e063e534987e21a15325319c4c2ba663e1c8c0a8a9f09104')
-sha256sums_aarch64=('5bd6284e8b91b39758e0c54a97b130f71a3882f1b57bd3987be38f62bd997b2c')
+makedepends=('dotnet-sdk-6.0')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('ff5c53b50383c0eb478d485981556ed350645f8e8bf380630b1b0c7d3794cf32')
options=('!strip')
+prepare() {
+ cd "${pkgname}-${pkgver}/src/QBittorrent.CommandLineInterface"
+
+ export DOTNET_CLI_TELEMETRY_OPTOUT=1
+ export DOTNET_NOLOGO=1
+
+ dotnet restore --use-current-runtime
+}
+
+build() {
+ cd "${pkgname}-${pkgver}/src/QBittorrent.CommandLineInterface"
+ dotnet build --no-restore -c Release -f net6 --no-self-contained --use-current-runtime "/p:Version=${pkgver}"
+}
+
package() {
+ cd "${pkgname}-${pkgver}/src/QBittorrent.CommandLineInterface"
+
install -d "${pkgdir}/usr/lib/${pkgname}"
- install -Dm755 -t "${pkgdir}/usr/lib/${pkgname}" qbt createdump
- install -Dm644 -t "${pkgdir}/usr/lib/${pkgname}" *.json *.so *.dll
+ dotnet publish --no-build --no-restore -c Release -f net6 --no-self-contained --use-current-runtime --output "${pkgdir}/usr/lib/${pkgname}"
install -d "${pkgdir}/usr/bin"
- ln -s "/usr/lib/${pkgname}/qbt" "${pkgdir}/usr/bin/qbt"
+ ln -st "${pkgdir}/usr/bin" "/usr/lib/${pkgname}/qbt"
}