summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Mao2023-10-14 12:16:21 +0800
committerLeo Mao2023-10-14 12:16:21 +0800
commitc4e02e71ee26b177f5d1c227a99e10c78d764994 (patch)
tree26501950e78d757f4a375b92d4778dc3b62085ef
parent37508cde90dfbea3fd14461fe34289ae7ebb5e60 (diff)
downloadaur-c4e02e71ee26b177f5d1c227a99e10c78d764994.tar.gz
upgpkg: python-imageio 2.31.5-4
Add python-wheel to makedepends and set --compile-bytecode to 1.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5b85230d644..52c19ca782f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-imageio
pkgdesc = a Python library that provides an easy interface to read and write a wide range of image data
pkgver = 2.31.5
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/imageio/imageio
arch = any
license = BSD
makedepends = python-build
makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python-numpy
depends = python-pillow
diff --git a/PKGBUILD b/PKGBUILD
index 8d338bec2aa3..a56b112c86d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="python-imageio"
_pkgname="imageio"
pkgver=2.31.5
-pkgrel=3
+pkgrel=4
pkgdesc="a Python library that provides an easy interface to read and write a wide range of image data"
arch=('any')
_github="imageio/imageio"
@@ -12,7 +12,7 @@ url="https://github.com/imageio/imageio"
license=('BSD')
depends=('python-numpy' 'python-pillow')
optdepends=('avbin' 'python-imageio-ffmpeg' 'freeimage' 'python-astropy' 'python-simpleitk')
-makedepends=('python-build' 'python-installer' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/imageio/imageio/archive/v${pkgver}.tar.gz")
sha256sums=('a04e1d87e01734c8981c2989b1d2b5bd729821705b09066cfc6c31d5ffe0ffd7')
@@ -24,7 +24,7 @@ build() {
package() {
cd "$srcdir/${_pkgname}-${pkgver}"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" --compile-bytecode=1 dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
# remove utilities for downloading binary dependencies