summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0b1001002021-11-25 16:46:35 +0100
committer0b1001002021-11-25 16:57:50 +0100
commitc5101bfdb6b7750f97bb30f772298a670d9a0e35 (patch)
tree3bb900b101614eab6855b9f0cce7d27d101ccd88
parent3e9e5804a550a8aad9b3dbdfd711a3e2055c45a1 (diff)
downloadaur-c5101bfdb6b7750f97bb30f772298a670d9a0e35.tar.gz
Update to 0.4b47 and remove patches
Change pkgdesc to upstream description Add some missing dependencies Enable readline support in restore binary Remove or replace unsupported configure options Exclude everything but some needed files in .gitignore
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD50
-rw-r--r--autoreconf.patch11
-rw-r--r--dump-buildfix.patch27
5 files changed, 35 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a16d848dc46..0fecf5b37e90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = dump
- pkgdesc = Standard *nix for performing backups to tapedrive from ext2 and ext3 filesystems
- pkgver = 0.4b46
- pkgrel = 2
+ pkgdesc = Dump/Restore ext2/3/4 filesystem backup
+ pkgver = 0.4b47
+ pkgrel = 1
url = http://dump.sourceforge.net/
arch = i686
arch = x86_64
license = BSD
- makedepends = autoconf
- makedepends = automake
- makedepends = pkg-config
- makedepends = openssl-1.0
+ makedepends = util-linux
+ makedepends = sqlite
+ makedepends = openssl
+ depends = util-linux-libs
+ depends = zlib
+ depends = bzip2
+ depends = lzo
+ depends = readline
+ depends = ncurses
depends = e2fsprogs
- source = http://downloads.sourceforge.net/dump/dump-0.4b46.tar.gz
- md5sums = 4c463f797e7e8a1112fabf5cbf8e1855
+ source = http://downloads.sourceforge.net/dump/dump-0.4b47.tar.gz
+ sha512sums = e9c567fe2ffad196b9657c551d83f7607758f3704cad6cb407514bbe2bc765c16968997dc3a5bc92b9eb5900fa5bd6e7cebc92c81afff53339fca92891a5259d
pkgname = dump
-
diff --git a/.gitignore b/.gitignore
index 4a3d82ac4f55..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,7 @@
-/dump-*.tar.gz
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 81d0defc047b..d2b1384710fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,35 @@
-# Maintainer: Phillip Smith <pkgbuild@phs.id.au>
+# Maintainer: 0b100100 <0b100100 at protonmail dot ch>
+# Contributor: Phillip Smith <pkgbuild@phs.id.au>
# Contributor: gregor <gregor@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
-### Please ask support questions about this software in one of:
-### 1) The AUR comments; OR
-### 2) Upstream forums/maillist etc; OR
-### 3) The ArchLinux forums
-### I do not always know enough about the software itself, or don't have the
-### time to promptly respond to direct emails.
-### If you have found a problem with the package/PKGBUILD (as opposed to
-### the software) then please do email me or post an AUR comment.
-
pkgname=dump
-pkgver=0.4b46
-pkgrel=2
-pkgdesc="Standard *nix for performing backups to tapedrive from ext2 and ext3 filesystems"
+pkgver=0.4b47
+pkgrel=1
+pkgdesc="Dump/Restore ext2/3/4 filesystem backup"
arch=('i686' 'x86_64')
url="http://dump.sourceforge.net/"
license=('BSD')
-depends=('e2fsprogs')
-makedepends=('autoconf' 'automake' 'pkg-config' 'openssl-1.0')
+depends=('util-linux-libs' 'zlib' 'bzip2' 'lzo' 'readline' 'ncurses' 'e2fsprogs')
+makedepends=('util-linux' 'sqlite' 'openssl')
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('4c463f797e7e8a1112fabf5cbf8e1855')
+sha512sums=('e9c567fe2ffad196b9657c551d83f7607758f3704cad6cb407514bbe2bc765c16968997dc3a5bc92b9eb5900fa5bd6e7cebc92c81afff53339fca92891a5259d')
build() {
cd "$srcdir"/$pkgname-$pkgver
-
- PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
- CFLAGS+=" -I/usr/include/openssl-1.0" \
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
+ --sbindir='${exec_prefix}/bin' \
--sysconfdir=/etc \
- --with-manowner=root \
- --with-mangrp=root \
- --with-manmode=644 \
- --with-bingrp=root \
- --disable-readline \
--disable-rmt \
- --disable-transselinux
-
+ --disable-selinux
make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
-
+ cd $pkgname-$pkgver
make prefix="$pkgdir"/usr install
-
- # the upstream Makefile doesn't care for --sbindir to work with
- # prefix=$pkgdir so manhandle /usr/sbin to /usr/bin
- mv -f "$pkgdir"/usr/sbin/ "$pkgdir"/usr/bin
-
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/dump/COPYING
+ install -Dm644 COPYING -t "$pkgdir"/usr/share/licenses/$pkgname
}
# vim:set ts=2 sw=2 et:
diff --git a/autoreconf.patch b/autoreconf.patch
deleted file mode 100644
index 9ca2e2876fd1..000000000000
--- a/autoreconf.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.OLD 2013-12-02 12:03:00.352853949 +1100
-+++ Makefile 2013-12-02 12:03:17.991990818 +1100
-@@ -73,7 +73,7 @@
- (cd $(top_builddir); ./config.status)
-
- $(top_srcdir)/configure: $(top_srcdir)/configure.in
-- cd $(top_srcdir) && autoconf
-+ cd $(top_srcdir) && autoreconf
-
- $(top_srcdir)/config.h.in: $(top_srcdir)/configure.in
- cd $(top_srcdir) && autoheader
diff --git a/dump-buildfix.patch b/dump-buildfix.patch
deleted file mode 100644
index 15d5a0c7da8f..000000000000
--- a/dump-buildfix.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -up dump-0.4b44/configure.in.buildfix dump-0.4b44/configure.in
---- dump-0.4b44/configure.in.buildfix 2011-06-14 14:37:49.659652746 +0200
-+++ dump-0.4b44/configure.in 2011-06-14 14:40:47.361349814 +0200
-@@ -415,6 +415,11 @@ if test "$ext2fs_h" = no -o "x$EXT2FS_LI
- AC_MSG_ERROR(You need to install the Ext2fs libraries from the E2fsprogs distribution first - hint: make install-libs)
- fi
-
-+PKG_CHECK_MODULES(COM_ERR, [com_err])
-+if test -n "$STATIC" ; then
-+ COM_ERR_LIBS=`$PKG_CONFIG --libs --static com_err`
-+fi
-+
- dnl
- dnl Check for ext2fs_read_inode_full
- dnl
-diff -up dump-0.4b44/MCONFIG.in.buildfix dump-0.4b44/MCONFIG.in
---- dump-0.4b44/MCONFIG.in.buildfix 2011-06-14 14:41:00.869323616 +0200
-+++ dump-0.4b44/MCONFIG.in 2011-06-14 14:41:12.947300187 +0200
-@@ -40,7 +40,7 @@ GINC+= @EXT2FS_CFLAGS@
- # indicate where the ext2fs library can be found (this is not needed if you
- # have run `make install-libs' in the e2fsprogs source directory).
- #GLIBDIR= -L/usr/src/e2fsprogs-0.5c/lib
--GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@
-+GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@ @COM_ERR_LIBS@
-
- #
- # Definitions (don't change them unless you know what you are doing)