summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-07-23 08:24:43 -0400
committerGuillaume Horel2021-07-23 08:24:43 -0400
commitc52de05a1e56436dec08eb1d836aef342d592660 (patch)
tree0f272998a6d4fc890fc6349aaaf045404076ab0e
parentc9763981608f85fdde8f304e07e7483969eed11a (diff)
downloadaur-c52de05a1e56436dec08eb1d836aef342d592660.tar.gz
remove wheel as well
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--install.patch13
3 files changed, 21 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d477e50f22ef..ac439627a7c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,8 @@ pkgbase = python-booleanoperations
depends = python-fonttools
options = !emptydirs
source = https://pypi.org/packages/source/b/booleanOperations/booleanOperations-0.9.0.zip
+ source = install.patch
sha256sums = 8cfa821c32ad374fa120d6b2e0b444ebeac57c91e6631528645fa19ac2a281b8
+ sha256sums = db49ee64cf2799da96c600570c3557ef2fee2998223d2ff5c0ad4ce62bfd4be6
pkgname = python-booleanoperations
diff --git a/PKGBUILD b/PKGBUILD
index a233cb46e9b0..aaad5895a455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,11 +13,14 @@ checkdepends=()
depends=('python-pyclipper' 'python-fonttools')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip")
-sha256sums=('8cfa821c32ad374fa120d6b2e0b444ebeac57c91e6631528645fa19ac2a281b8')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip"
+ 'install.patch')
+sha256sums=('8cfa821c32ad374fa120d6b2e0b444ebeac57c91e6631528645fa19ac2a281b8'
+ 'db49ee64cf2799da96c600570c3557ef2fee2998223d2ff5c0ad4ce62bfd4be6')
prepare() {
- sed -i '/setuptools_scm/d' "$_pkgname-$pkgver"/setup.cfg
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../install.patch
}
build() {
diff --git a/install.patch b/install.patch
new file mode 100644
index 000000000000..2bfbdbb52bd5
--- /dev/null
+++ b/install.patch
@@ -0,0 +1,13 @@
+diff -urN booleanOperations-0.9.0-orig/setup.cfg booleanOperations-0.9.0/setup.cfg
+--- booleanOperations-0.9.0-orig/setup.cfg 2021-07-23 08:19:06.148410072 -0400
++++ booleanOperations-0.9.0/setup.cfg 2021-07-23 08:19:20.288411176 -0400
+@@ -23,9 +23,6 @@
+ package_dir = =Lib
+ packages = find:
+ python_requires = >=3.6
+-setup_requires =
+- setuptools_scm
+- wheel
+ install_requires =
+ pyclipper >= 1.1.0.post1
+ fonttools >= 4.0.2